MSP-FET430 Flash Emulation Tool (FET) (for Use With Code Composer Essentials for MSP430 Version 3.1)

User's Guide
## Contents

**Preface** ......................................................................................................................................................................................... 7

1  **Get Started Now!** ............................................................................................................................................................ 11
   1.1  Flash Emulation Tool (FET) Overview .............................................................................................................................. 12
   1.2  Kit Contents, MSP-FET430PIF ............................................................................................................................................. 12
   1.3  Kit Contents, eZ430-F2013 .................................................................................................................................................... 12
   1.4  Kit Contents, eZ430-T2012 .................................................................................................................................................... 12
   1.5  Kit Contents, eZ430-F2500 .................................................................................................................................................... 13
   1.6  Kit Contents, MSP-FET430UIF ............................................................................................................................................. 13
   1.7  Kit Contents, MSP-FET430Uxx (‘U14, ’U28, ’U38, ’U23x0, ’U48, ’U64, ’U80, ’U100, ’U100A, ’U5x100) .......... 13
   1.8  Kit Contents, MSP-TS430xx (PM64, ’PZ100A, ’PZ5x100) ...................................................................................................... 14
   1.9  Software Installation ............................................................................................................................................................ 16
   1.10 Hardware Installation, MSP-FET430PIF ............................................................................................................................. 16
   1.11 Hardware Installation, MSP-FET430UIF ............................................................................................................................. 16
   1.12 Hardware Installation, eZ430-F2013, eZ430-RF2500 ........................................................................................................... 17
   1.13 Hardware Installation, MSP-FET430Uxx (‘U14, ’U28, ’U38, ’U23x0, ’U48, ’U64, ’U80, ’U100, ’U100A, ’U5x100) and MSP-TS430xxx (PM64, ’PZ100A, ’PZ5x100) .......................................................... 17
   1.14 Flashing the LED .............................................................................................................................................................. 17
   1.15 Important MSP430 Documents on the CD-ROM and Web ............................................................................................... 18

2  **Development Flow** ......................................................................................................................................................... 19
   2.1  Using Code Composer Essentials (CCE) .......................................................................................................................... 20
       2.1.1 Creating a Project From Scratch ................................................................................................................................ 20
       2.1.2 Project Settings ............................................................................................................................................................. 21
       2.1.3 Using an Existing CCE v3 or CCE v2.x Project .............................................................................................................. 21
       2.1.4 Stack Management ....................................................................................................................................................... 21
       2.1.5 How to Generate Binary-Format Files (TI-TXT and INTEL-HEX) ................................................................................ 21
       2.1.6 Overview of Example Programs and Projects ............................................................................................................. 22
   2.2 Using the Integrated Debugger ........................................................................................................................................... 22
       2.2.1 Breakpoint Types .......................................................................................................................................................... 22
       2.2.2 Using Breakpoints ....................................................................................................................................................... 23

3  **Design Considerations for In-Circuit Programming** ....................................................................................................... 25
   3.1 Signal Connections for In-System Programming and Debugging, MSP-FET430PIF, MSP-FET430UIF, MSP-GANG430, MSP-PRGS430 ................................................................. 26
   3.2 External Power ................................................................................................................................................................. 28
   3.3 Bootstrap Loader .............................................................................................................................................................. 29

A  **Frequently Asked Questions** ............................................................................................................................................. 31
   A.1 Hardware ........................................................................................................................................................................... 32
   A.2 Program Development (Assembler, C-Compiler, Linker, IDE) ......................................................................................... 33
   A.3 Debugging ........................................................................................................................................................................ 34

B  **Hardware** ........................................................................................................................................................................ 37
   B.1 Schematics and PCBs ......................................................................................................................................................... 38

---

SLAU157I—May 2005—Revised February 2009
Submit Documentation Feedback
B.2 MSP-FET430UIF Revision History

C IAR 2.x/3.x/4.x to CCE C-Migration
C.1 Interrupt Vector Definition
C.2 Intrinsic Functions
C.3 Data and Function Placement
C.3.1 Data Placement at an Absolute Location
C.3.2 Data Placement Into Named Segments
C.3.3 Function Placement Into Named Segments
C.4 C Calling Conventions
C.5 Other Differences
C.5.1 Initializing Static and Global Variables
C.5.2 Custom Boot Routine
C.5.3 Predefined Memory Segment Names
C.5.4 Predefined Macro Names

D IAR 2.x/3.x/4.x to CCE Assembler Migration
D.1 Sharing C/C++ Header Files With Assembly Source
D.2 Segment Control
D.3 Translating A430 Assembler Directives to Asm430 Directives
D.3.1 Introduction
D.3.2 Character Strings
D.3.3 Section Control Directives
D.3.4 Constant Initialization Directives
D.3.5 Listing Control Directives
D.3.6 File Reference Directives
D.3.7 Conditional Assembly Directives
D.3.8 Symbol Control Directives
D.3.9 Macro Directives
D.3.10 Miscellaneous Directives
D.3.11 Alphabetical Listing and Cross Reference of Asm430 Directives
D.3.12 Unsupported A430 Directives (IAR)

E FET-Specific Menus
E.1 Menus
E.1.1 Debug View: Advanced Run → Free Run
E.1.2 Target → Connect Target
E.1.3 Target → Make Device Secure
E.1.4 Project → Properties → TI Debug Settings → Target → MSP430 Properties → Clock Control
E.1.5 Window → Show View → Breakpoints
E.1.6 Window → Show View → Trace
E.1.7 Project → Properties → TI Debug Properties → Target → MSP430 Properties → Target Voltage

F Hardware Installation Guide
F.1 Hardware Installation

Document Revision History

Important Notices
List of Figures

3-1 Signal Connections for 4-Wire JTAG Communication ................................................. 27
3-2 Signal Connections for 2-Wire JTAG Communication (Spy-Bi-Wire) ......................... 28
B-1 MSP-TS430PW14 Target Socket Module, Schematic .................................................. 38
B-2 MSP-TS430PW14 Target Socket Module, PCB .......................................................... 39
B-3 MSP-TS430DW28 Target Socket Module, Schematic .................................................. 40
B-4 MSP-TS430DW28 Target Socket Module, PCB .......................................................... 41
B-5 MSP-TS430PW28 Target Socket Module, Schematic .................................................. 42
B-6 MSP-TS430PW28 Target Socket Module, PCB .......................................................... 43
B-7 MSP-TS430DA38 Target Socket Module, Schematic .................................................. 44
B-8 MSP-TS430DA38 Target Socket Module, PCB .......................................................... 45
B-9 MSP-TS430QFN23x0 Target Socket Module, Schematic ................................................. 46
B-10 MSP-TS430QFN23x0 Target Socket Module, PCB ..................................................... 47
B-11 MSP-TS430DL48 Target Socket Module, Schematic .................................................. 48
B-12 MSP-TS430DL48 Target Socket Module, PCB .......................................................... 49
B-13 MSP-TS430PM64 Target Socket Module, Schematic .................................................. 50
B-14 MSP-TS430PM64 Target Socket Module, PCB .......................................................... 51
B-15 MSP-TS430PN80 Target Socket Module, Schematic .................................................. 52
B-16 MSP-TS430PN80 Target Socket Module, PCB .......................................................... 53
B-17 MSP-TS430PZ100 Target Socket Module, Schematic .................................................. 54
B-18 MSP-TS430PZ100 Target Socket Module, PCB .......................................................... 55
B-19 MSP-TS430PZ100A Target Socket Module, Schematic ............................................... 56
B-20 MSP-TS430PZ100A Target Socket Module, PCB ........................................................ 57
B-21 MSP-TS430PZ5x100 Target Socket Module, Schematic ............................................... 58
B-22 MSP-TS430PZ5x100 Target Socket Module, PCB ....................................................... 59
B-23 MSP-FET430PIF FET Interface Module, Schematic ................................................... 60
B-24 MSP-FET430PIF FET Interface Module, PCB ............................................................ 61
B-25 MSP-FET430UIF USB Interface, Schematic (1 of 4) .................................................... 62
B-26 MSP-FET430UIF USB Interface, Schematic (2 of 4) .................................................... 63
B-27 MSP-FET430UIF USB Interface, Schematic (3 of 4) .................................................... 64
B-28 MSP-FET430UIF USB Interface, Schematic (4 of 4) .................................................... 65
B-29 MSP-FET430UIF USB Interface, PCB ..................................................................... 66
F-1 WinXP Hardware Recognition .................................................................................... 90
F-2 WinXP Hardware Wizard ........................................................................................... 90
F-3 WinXP Driver Location Selection Folder ..................................................................... 91
F-4 WinXP Driver Installation .......................................................................................... 92
F-5 Device Manager Using MSP-FET430UIF or eZ430-F2013 .......................................... 93
F-6 Device Manager Using eZ430-RF2500 ..................................................................... 94
List of Tables

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1-1</td>
<td>Flash Emulation Tool (FET) Features</td>
<td>12</td>
</tr>
<tr>
<td>1-2</td>
<td>System Requirements</td>
<td>16</td>
</tr>
<tr>
<td>1-3</td>
<td>Code Examples</td>
<td>17</td>
</tr>
<tr>
<td>2-1</td>
<td>Device Breakpoints and Other Emulation Features</td>
<td>22</td>
</tr>
</tbody>
</table>
About This Manual

This manual describes the Texas Instruments MSP-FET430 Flash Emulation Tool (FET). The FET is the program development tool for the MSP430 ultra-low-power microcontroller. Both available interface types, the parallel port interface and the USB interface, are described.

How to Use This Manual

Read and follow the instructions in the Get Started Now! chapter. This chapter lists the contents of the FET, provides instructions on installing the software and hardware, and describes how to run the demonstration programs. After you see how quick and easy it is to use the FET, TI recommends that you read all of this manual.

This manual describes the setup and operation of the FET but does not fully describe the MSP430 or the development software systems. For details of these items, see the appropriate TI documents listed in Section 1.15, Important MSP430 Documents on the CD-ROM and Web.

This manual applies to the following tools (and devices):

- MSP-FET430PIF (debug interface with parallel port connection, for all MSP430 flash-based devices)
- MSP-FET430UIF (debug interface with USB connection, for all MSP430 flash-based devices)
- eZ430-F2013 (USB stick form factor interface with attached MSP430F2013 target, for all MSP430F20xx devices)
- eZ430-T2012 (three MSP430F2012 based target boards)
- eZ430-RF2500 (USB stick form factor interface with attached MSP430F2274/CC2500 target, for all MSP430F20xx and MSP430F22xx devices)
The following tools contain the USB debug interface (MSP-FET430UIF) and the respective target socket module:

- MSP-FET430U14 (for MSP430 devices in 14-pin PW packages)
- MSP-FET430U28 (for MSP430 devices in 20- and 28-in DW or PW packages)
- MSP-FET430U38 (for MSP430 devices in 38-pin DA packages)
- MSP-FET430U23x0 (for MSP430F23x0 devices in 40-pin RHA packages only)
- MSP-FET430U48 (for MSP430 devices in 48-pin DL package)
- MSP-FET430U64 (for MSP430 devices in 64-pin PM package)
- MSP-FET430U80 (for MSP430 devices in 80-pin PN package)
- MSP-FET430U100 (for MSP430 devices in 100-pin PZ package)
- MSP-FET430U100A (for MSP430F471xx devices in 100-pin PZ package - red PCB)
- MSP-FET430U5x100 (for MSP430F5x devices in 100-pin PZ packages)

Stand-alone target-socket modules (without debug interface):

- MSP-TS430PM64 (for MSP430 devices in 64-pin PM package)
- MSP-TS430PZ100A (for MSP430F471xx devices in 100-pin PZ package - red PCB)
- MSP-TS430PZ5x100 (for MSP430F5x devices in 100-pin PZ packages)

These tools contain the most up-to-date materials available at the time of packaging. For the latest materials (data sheets, user's guides, software, application information, etc.), visit the TI MSP430 web site at www.ti.com/msp430 or contact your local TI sales office.

Information About Cautions and Warnings

This document may contain cautions and warnings.

CAUTION

This is an example of a caution statement.
A caution statement describes a situation that could potentially damage your software or equipment.

WARNING

This is an example of a warning statement.
A warning statement describes a situation that could potentially cause harm to you.

The information in a caution or a warning is provided for your protection. Read each caution and warning carefully.

Related Documentation From Texas Instruments

MSP430xxxx device data sheets

MSP430x1xx Family User's Guide, literature number SLAU049
MSP430x2xx Family User's Guide, literature number SLAU144
MSP430x3xx Family User's Guide, literature number SLAU012
MSP430x4xx Family User's Guide, literature number SLAU056
MSP430x5xx Family User's Guide, literature number SLAU208
If You Need Assistance

Support for the MSP430 devices and the FET development tools is provided by the Texas Instruments Product Information Center (PIC). Contact information for the PIC can be found on the TI web site at www.ti.com/support. A Code Composer Essentials specific Wiki page (FAQ) is available, and the Texas Instruments E2E Community support forums provide open interaction with peer engineers, TI engineers, and other experts. Additional device-specific information can be found on the MSP430 web site.

FCC Warning

This equipment is intended for use in a laboratory test environment only. It generates, uses, and can radiate radio frequency energy and has not been tested for compliance with the limits of computing devices pursuant to subpart J of part 15 of FCC rules, which are designed to provide reasonable protection against radio-frequency interference. Operation of this equipment in other environments may cause interference with radio communications, in which case, the user is required to take whatever measures may be required to correct this interference at his own expense.
This chapter lists the contents of the FET, provides instruction on installing the software and hardware, and shows how to run the demonstration programs.

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.1 Flash Emulation Tool (FET) Overview</td>
<td>12</td>
</tr>
<tr>
<td>1.2 Kit Contents, MSP-FET430PIF</td>
<td>12</td>
</tr>
<tr>
<td>1.3 Kit Contents, eZ430-F2013</td>
<td>12</td>
</tr>
<tr>
<td>1.4 Kit Contents, eZ430-T2012</td>
<td>12</td>
</tr>
<tr>
<td>1.5 Kit Contents, eZ430-F2500</td>
<td>13</td>
</tr>
<tr>
<td>1.6 Kit Contents, MSP-FET430UIF</td>
<td>13</td>
</tr>
<tr>
<td>1.7 Kit Contents, MSP-FET430Uxx ('U14, 'U28, 'U38, 'U23x0, 'U48, 'U64, 'U80, 'U100, 'U100A, 'U5x100)</td>
<td>13</td>
</tr>
<tr>
<td>1.8 Kit Contents, MSP-TS430xx ('PM64, 'PZ100A, 'PZ5x100)</td>
<td>14</td>
</tr>
<tr>
<td>1.9 Software Installation</td>
<td>16</td>
</tr>
<tr>
<td>1.10 Hardware Installation, MSP-FET430PIF</td>
<td>16</td>
</tr>
<tr>
<td>1.11 Hardware Installation, MSP-FET430UIF</td>
<td>16</td>
</tr>
<tr>
<td>1.12 Hardware Installation, eZ430-F2013, eZ430-RF2500</td>
<td>17</td>
</tr>
<tr>
<td>1.13 Hardware Installation, MSP-FET430Uxx ('U14, 'U28, 'U38, 'U23x0, 'U48, 'U64, 'U80, 'U100, 'U100A, 'U5x100) and MSP-TS430xxx ('PM64, 'PZ100A, 'PZ5x100)</td>
<td>17</td>
</tr>
<tr>
<td>1.14 Flashing the LED</td>
<td>17</td>
</tr>
<tr>
<td>1.15 Important MSP430 Documents on the CD-ROM and Web</td>
<td>18</td>
</tr>
</tbody>
</table>
1.1 Flash Emulation Tool (FET) Overview

TI offers several flash emulation tools to meet different requirements.

<table>
<thead>
<tr>
<th>Table 1-1. Flash Emulation Tool (FET) Features</th>
</tr>
</thead>
<tbody>
<tr>
<td>Supports all MSP430 flash-based devices (F1xx, F2xx, F4xx, F5xx)</td>
</tr>
<tr>
<td>Supports MSP430F20xx devices only</td>
</tr>
<tr>
<td>Supports MSP430F20xx/F21xx/F22xx only</td>
</tr>
<tr>
<td>Allows fuse blow</td>
</tr>
<tr>
<td>Adjustable target supply voltage</td>
</tr>
<tr>
<td>Fixed 2.8-V target supply voltage</td>
</tr>
<tr>
<td>Fixed 3.6-V target supply voltage</td>
</tr>
<tr>
<td>4-wire JTAG</td>
</tr>
<tr>
<td>2-wire JTAG(1)</td>
</tr>
<tr>
<td>Application UART</td>
</tr>
<tr>
<td>Supported by CCE</td>
</tr>
<tr>
<td>Supported by IAR</td>
</tr>
</tbody>
</table>

(1) The 2-wire JTAG debug interface is also referred to as Spy-Bi-Wire (SBW) interface.

1.2 Kit Contents, MSP-FET430PIF
- One READ ME FIRST document
- One MSP430 CD-ROM
- One MSP-FET430PIF interface module
- One 25-conductor cable
- One 14-conductor cable

1.3 Kit Contents, eZ430-F2013
- One QUICK START GUIDE document
- One eZ430-F2013 CD-ROM
- One eZ430-F2013 development tool including one MSP430F2013 target board

1.4 Kit Contents, eZ430-T2012
- Three MSP430F2012 based target boards
1.5 Kit Contents, eZ430-F2500
- One QUICK START GUIDE document
- One eZ430-RF2500 CD-ROM
- One eZ430-RF2500 development tool including one MSP430F2274/CC2500 target board
- One eZ430-RF2500T target board with battery holder and batteries

1.6 Kit Contents, MSP-FET430UIF
- One READ ME FIRST document
- One MSP430 CD-ROM
- One MSP-FET430UIF interface module
- One USB cable
- One 14-conductor cable

1.7 Kit Contents, MSP-FET430Uxx ('U14, 'U28, 'U38, 'U23x0, 'U48, 'U64, 'U80, 'U100, 'U100A, 'U5x100)
- One READ ME FIRST document
- One MSP430 CD-ROM
- One MSP-FETP430UIF USB interface module. This is the unit that has a USB B-connector on one end of the case and a 2x7-pin male connector on the other end of the case.
- One 32.768-kHz crystal
- One target socket module
  MSP-FET430U14: One MSP-TS430PW14 target socket module. This is the PCB on which is mounted a 14-pin ZIF socket. It fits all MSP430 devices in 14-pin PW packages. A 2x7-pin male connector is also present on the PCB.
  MSP-FET430U28: One MSP-TS430PW28 target socket module. This is the PCB on which is mounted a 28-pin ZIF socket. It fits all MSP430 devices in 20- and 28-pin PW packages. A 2x7-pin male connector is also present on the PCB.
  MSP-FET430U38: One MSP-TS430DA38 target socket module. This is the PCB on which is mounted a 38-pin ZIF socket. It fits all MSP430 devices in 38-pin DA packages. A 2x7-pin male connector is also present on the PCB.
  MSP-FET430U23x0: One MSP-TS430QFN23x0 target socket module (former name MSP-TS430QFN40). This is the PCB on which is mounted a 40-pin ZIF socket. It fits only MSP430F2330/F2350/F2370 devices in 40-pin RHA packages. A 2x7-pin male connector is also present on the PCB.
  MSP-FET430U48: One MSP-TS430DL48 target socket module. This is the PCB on which is mounted a 48-pin ZIF socket. It fits all MSP430 devices in 48-pin DL packages. A 2x7-pin male connector is also present on the PCB.
  MSP-FET430U64: One MSP-TS430PM64 target socket module. This is the PCB on which is mounted a 64-pin ZIF socket. It fits all MSP430 devices in 64-pin PM packages. A 2x7-pin male connector is also present on the PCB.
  MSP-FET430U80: One MSP-TS430PN80 target socket module. This is the PCB on which is mounted a 80-pin ZIF socket. It fits all MSP430 devices in 80-pin PN packages. A 2x7-pin male connector is also present on the PCB.
  MSP-FET430U100: One MSP-TS430PZ100 target socket module. This is the PCB on which is mounted a 100-pin ZIF socket. It fits all MSP430 devices in 100-pin PZ packages. A 2x7-pin male connector is also present on the PCB.
  MSP-FET430U100A: One MSP-TS430PZ100A target socket module (red PCB). This is the PCB on which is mounted a 100-pin ZIF socket. It fits all MSP430F471xx devices in 100-pin PZ packages. A 2x7-pin male connector is also present on the PCB.
  MSP-FET430U5x100: One MSP-TS430P5x100 target socket module. This is the PCB on which is mounted a 100-pin ZIF socket. It fits all MSP430F5x devices in 100-pin PZ packages. A 2x7-pin male connector is also present on the PCB.
• One USB cable
• One 14-conductor cable
• Four or eight PCB headers
  MSP-FET430U14: Four PCB 1×7-pin headers (two male and two female)
  MSP-FET430U28: Four PCB 1×14-pin headers (two male and two female)
  MSP-FET430U38: Four PCB 1×19-pin headers (two male and two female)
  MSP-FET430U23x0: Eight PCB 1×10-pin headers (four male and four female)
  MSP-FET430U48: Four PCB 2×24-pin headers (two male and two female)
  MSP-FET430U64: Eight PCB 1×16-pin headers (four male and four female)
  MSP-FET430U80: Eight PCB 1×20-pin headers (four male and four female)
  MSP-FET430U100: Eight PCB 1×25-pin headers (four male and four female)
  MSP-FET430U100A: Eight PCB 1×25-pin headers (four male and four female)
• One small box containing two or four MSP430 device samples
  MSP-FET430U14: MSP430F2013IPW
  MSP-FET430U28: MSP430F2132IPW
  MSP-FET430U38: MSP430F2274IDA
  MSP-FET430U23x0: MSP430F2370RHA
  MSP-FET430U48: MSP430F4270IDL
  MSP-FET430U64: MSP430F417IPM and MSP430F416IPM
  MSP-FET430U80: MSP430FG439IPN
  MSP-FET430U100: MSP430FG4619IPZ
  MSP-FET430U100A: MSP430F47197IPZ
  MSP-FET430U5x100: MSP430F5438IPZ

Consult the device data sheets for device specifications. Device errata can be found in the respective device product folder on the web, provided as a PDF document. Depending on the device, errata also may be found in the device bug database at www.ti.com/sc/cgi-bin/buglist.cgi.

1.8 Kit Contents, MSP-TS430xx (‘PM64, ‘PZ100A, ’PZ5x100)
• One README FIRST document
• One MSP430 CD-ROM
• One 32.768-kHz crystal
• One target socket module
  MSP-TS430PM64: One MSP-TS430PM64 target socket module. This is the PCB on which is mounted a 64-pin ZIF socket. It fits all MSP430 devices in 64-pin PM packages. A 2×7-pin male connector is also present on the PCB.
  MSP-TS430PZ100A: One MSP-TS430PZ100A target socket module (red PCB). This is the PCB on which is mounted a 100-pin ZIF socket. It fits all MSP430F471xx devices in 100-pin PZ packages. A 2×7-pin male connector is also present on the PCB.
  MSP-TS430U5x100: One MSP-TS430PZ5x100 target socket module. This is the PCB on which is mounted a 100-pin ZIF socket. It fits all MSP430F5x devices in 100-pin PZ packages. A 2×7-pin male connector is also present on the PCB.
• Eight PCB headers
  MSP-TS430PM64: Eight PCB 1×16-pin headers (four male and four female)
  MSP-TS430PZ100A: Eight PCB 1×25-pin headers (four male and four female)
  MSP-TS430PZ5x100: Eight PCB 1×25-pin headers (four male and four female)
• One small box containing two MSP430 device samples
  MSP-TS430PM64: MSP430F417IPM and MSP430F169IPM
  MSP-TS430PZ100A: MSP430F47197IPZ
  MSP-TS430PZ5x100: MSP430F5438IPZ
Consult the device data sheets for device specifications. Device errata can be found in the respective device product folder on the web, provided as a PDF document. Depending on the device, errata also may be found in the device bug database at www.ti.com/sc/cgi-bin/buglist.cgi.
1.9 Software Installation

To install Code Composer Essentials v3.1 for MSP430 (CCE), run setup_CCE_3.x.x.x_x_MSP430.exe from the CD-ROM or download location and follow the instructions shown on the screen. The hardware drivers for the parallel-port FET (MSP-FET430PIF) and the drivers for the USB JTAG emulator (MSP-FET430UIF) are installed automatically when installing CCE.

<table>
<thead>
<tr>
<th>Processor</th>
<th>Recommended System Requirements</th>
<th>Minimum System Requirements</th>
</tr>
</thead>
<tbody>
<tr>
<td>RAM</td>
<td>Pentium 4 or similar</td>
<td>Pentium 3 or similar</td>
</tr>
<tr>
<td>Free Disk Space</td>
<td>1 GB</td>
<td>512 MB</td>
</tr>
<tr>
<td>Operating System</td>
<td>500 MB</td>
<td>450 MB</td>
</tr>
<tr>
<td></td>
<td>Microsoft® Windows® XP with SP2 (32 bit) or Windows Vista® (32 bit)</td>
<td>Microsoft® Windows® XP with SP2 (32 bit) or Windows Vista® (32 bit)</td>
</tr>
</tbody>
</table>

1.10 Hardware Installation, MSP-FET430PIF

Follow these steps to install the hardware for the MSP-FET430PIF tools:

1. Use the 25-conductor cable to connect the FET interface module to the parallel port of the PC. The necessary driver for accessing the PC parallel port is installed automatically during CCE installation. Note that a restart is required after the CCE installation for the driver to become active.
2. Use the 14-conductor cable to connect the parallel-port debug interface module to a target board, such as an MSP-TS430xxx target socket module. Module schematics and PCBs are shown in Appendix B.

1.11 Hardware Installation, MSP-FET430UIF

Follow these steps to install the hardware for the MSP-FET430UIF tool:

1. Use the USB cable to connect the USB-FET interface module to a USB port on the PC. The USB FET should be recognized, as the USB device driver should have been installed already with the CCE software. If the install wizard starts, follow the prompts and point the wizard to the driver files located in C:\Program Files\Texas Instruments\MSP430_USB_DRIVERS_v3 (this is the default location unless another installation directory was specified during CCE installation). Detailed driver installation instructions are found in Appendix F.
2. After connecting to a PC, the USB FET performs a selftest during which the red LED flashes for about two seconds. If the selftest passes successfully, the green LED lights permanently.
3. Use the 14-conductor cable to connect the USB-FET interface module to a target board, such as an MSP-TS430xxx target socket module.
4. Ensure that the MSP430 device is securely seated in the socket, and that its pin 1 (indicated with a circular indentation on the top surface) aligns with the “1” mark on the PCB.
5. Compared to the parallel-port debug interface, the USB FET has additional features including JTAG security fuse blow and adjustable target $V_{CC}$ (1.8 V to 3.6 V). Supply the module with up to 100 mA.
1.12 **Hardware Installation, eZ430-F2013, eZ430-RF2500**

Follow these steps to install the hardware for the eZ430-F2013 and eZ430-RF2500 tools:

1. Connect the eZ430-F2013 or eZ430-RF2500 to a USB port of the PC.
2. The USB FET should be recognized by the PC. The USB device driver should have been installed with Code Composer Essentials. If the install wizard starts, follow the prompts and point the wizard to the driver files located in C:\Program Files\Texas Instruments\MSP430_USB_DRIVERS_v3\ (this is the default location unless another installation directory was specified during CCE installation). Detailed driver installation instructions can be found in Appendix F.

1.13 **Hardware Installation, MSP-FET430Uxx ('U14, 'U28, 'U38, 'U23x0, 'U48, 'U64, 'U80, 'U100, 'U100A, 'U5x100) and MSP-TS430xxx (PM64, 'PZ100A, 'PZ5x100)**

Follow these steps to install the hardware for the MSP-FET430Uxx and MSP-TS430xxx tools:

1. Connect the MSP-FET430PIF or MSP-FET430UIF debug interface to the appropriate port of the PC. Use the 14-conductor cable to connect the FET interface module to the supplied target socket module.
2. Ensure that the MSP430 device is securely seated in the socket and that its pin 1 (indicated with a circular indentation on the top surface) aligns with the "1" mark on the PCB.
3. Ensure that the two jumpers (LED and $V_{CC}$) near the 2x7-pin male connector are in place. Illustrations of the target socket modules and their parts are found in Appendix B.

1.14 **Flashing the LED**

This section demonstrates on the FET the equivalent of the C-language "Hello world!" introductory program. CCEv3.1 includes plain C and ASM code files as well as fully preconfigured projects. The following describes how an application that flashes the LED is developed, downloaded to the FET, and run.

2. Create a new Project by selecting File → New → Managed Make C/ASM Project (recommended).
3. Enter a project name and click next until the Device Selection Page is shown. Select the Device Variant used in the project.
4. Add the flashing LED code example to the project by clicking Project → Add Files to Active Project. Code examples are located in `<Installation Root>\examples\msp430`. Use Table 1-3 to select the appropriate source code file:

<table>
<thead>
<tr>
<th>MSP430 Devices</th>
<th>Code Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>MSP430x1xx device family</td>
<td><code>&lt;...&gt;\msp430x1xx\C-Source\msp430x1xx.c</code></td>
</tr>
<tr>
<td>MSP430x2xx device family</td>
<td><code>&lt;...&gt;\msp430x2xx\C-Source\msp430x2xx.c</code></td>
</tr>
<tr>
<td>MSP430x4xx device family</td>
<td><code>&lt;...&gt;\msp430x4xx\C-Source\msp430x4xx.c</code></td>
</tr>
<tr>
<td>MSP430x5xx device family</td>
<td><code>&lt;...&gt;\msp430x5xx\C-Source\msp430x5xx.c</code></td>
</tr>
</tbody>
</table>

5. If using a USB Flash Emulation Tool such as the MSP-FET430UIF or the eZ430 Development Tool, they should be already configured by default. The debug interface may be changed via Project → Properties → TI Debug Settings → Setup.
6. To compile the code and download the application to the target device, go to Run → Debug Active Project.
7. The application may be started by selecting Run → Run (F8) or clicking the Play button on the toolbar. See FAQ Debugging #1 if the CCE debugger is unable to communicate with the device.

Congratulations, you have just built and tested an MSP430 application!
Predefined projects, which are located in `<Installation Root>\examples\msp430\example projects`, can be imported by selecting File → Import → General → Existing Project.
1.15 Important MSP430 Documents on the CD-ROM and Web

The primary sources of MSP430 information are the device-specific data sheets and user's guides. The most up-to-date versions of these documents available at the time of production have been provided on the CD-ROM included with this tool. The MSP430 web site (www.ti.com/msp430) contains the latest version of these documents.
This chapter discusses how to use Code Composer Essentials (CCE) to develop application software and how to debug that software.

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>2.1 Using Code Composer Essentials (CCE)</td>
<td>20</td>
</tr>
<tr>
<td>2.2 Using the Integrated Debugger</td>
<td>22</td>
</tr>
</tbody>
</table>
2.1 Using Code Composer Essentials (CCE)

The following sections are a brief overview of how to use CCE. For a full discussion of software development flow with CCE in assembly or C, see MSP430 Assembly Language Tools User’s Guide (SLAU131) and MSP430 Optimizing C/C++ Compiler User’s Guide (SLAU132).

2.1.1 Creating a Project From Scratch

This section presents step-by-step instructions to create an assembly or C project from scratch and to download and run the application on the MSP430 (see Section 2.1.2, Project Settings). Also, the MSP430 Code Composer Essentials Help presents a more comprehensive overview of the process.

1. Start the CCE (Start → All Programs → Texas Instruments → Code Composer Essentials v3.1 → Code Composer Essentials v3.1).
2. Create new project (File → New → Project → C → Managed Make C/ASM Project (Recommended)). Click Next and enter the name for the project. Click Next until reaching the New Project window titled Device Selection. Select the appropriate device and click Finish. For assembly only projects ensure to click “Configure as an assembly only project.”
3. Create a new source file (File → New → Source File). Enter file name and remember to add the suffix .c or .asm. If, instead, the user wants to use an existing source file for his/her project, click Project → Add Files to Active Project and browse to the file of interest. Single click on the file and click Open or double-click on the file name to complete the addition of the file into the project folder. Note that adding a file to the project makes a copy of the file in the project directory. To point to a file in the directory structure without physically adding it to the project directory, click Project → Link Files to Active Project instead.
4. Enter the program text into the file.

**Note:** Use .h files to simplify code development.

CCE is supplied with files for each device that define the device registers and the bit names. Using these files is recommended and can greatly simplify the task of developing a program. To include the .h file corresponding to the target device, add the line \#include <msp430xyyy.h> for C and .cdecls C,LIST,“msp430xyyy” for assembly code, where xyyy specifies the MSP430 part number.

5. Configure the project options (Project → Properties); e.g., to select debug interface, or accept the default factory settings.
6. Build the project (Project → Build Active Project).
7. Debug the application (Run → Debug Active Project). This starts the debugger, which gains control of the target, erases the target memory, programs the target memory with the application, and resets the target. See FAQ Debugging #1 if the debugger is unable to communicate with the device.
8. Click Run → Run to start the application.
9. Click Run → Terminate to stop the application and to exit the debugger. To return to the code editor, click Window → Open Perspective → C/C++ or use the tab on the right top corner of CCE.
10. Click File → Exit to exit CCE.
2.1.2 Project Settings

The settings required to configure the CCE are numerous and detailed. Most projects can be compiled and debugged with default factory settings. The project settings are accessed by clicking Project → Properties for the active project. The following project settings are recommended/required:

- Specify the target device for debug session (Project → Properties → TI Build Settings → Device Variant). The corresponding Linker Command File is selected automatically.
- To more easily debug a C project, disable optimization (Project → Properties → C/C++ Build → Tool Settings → MSP430 Compiler → Optimization).
- Specify the search path for the C preprocessor (Project → Properties → C/C++ Build → Tool Settings → MSP430 Compiler → General Options).
- Specify the search path for any libraries being used (Project → Properties → C/C++ Build → Tool Settings → MSP430 Linker → File Search Path).
- Specify the debugger interface. Select Project → Properties → TI Debug Settings → Setup → Connection → TI MSP430 LPTx for the parallel FET interface or TI MSP430 USBx for the USB interface.
- Enable the erasure of the Main and Information memories before object code download (Project → Properties → TI Debug Settings → Target → MSP430 Properties → Download Options → Erase Main and Information Memory).
- To ensure proper standalone operation, disable Software Breakpoints (Project → Properties → TI Debug Settings → Target → MSP430 Properties → Use Software Breakpoints). If Software Breakpoints are enabled, ensure proper termination of each debug session while the target is connected; otherwise, the target may not be operational standalone.

2.1.3 Using an Existing CCE v3 or CCE v2.x Project

CCE v3.1 supports the conversion of workspaces and projects created in version 2 and 3 to the version 3.1 format (File → Import → General → Existing Projects into Workspace → Next). Browse to legacy CCE workspace containing the project to be imported. The Import Wizard lists all projects in the given workspace. Specific Projects can then be selected and converted.

While the support for assembly projects has not changed, the header files for C code have been modified slightly to improve compatibility with the IAR Embedded Workbench® IDE (interrupt vector definitions). The definitions used in CCE 2.x are still given, but have been commented out in all header files. To support CCE 2.x C code, remove the "/" in front of #define statements, which are located at the end of each .h file, in the section "Interrupt Vectors".

2.1.4 Stack Management

The reserved stack size can be configured through the project options dialog (Project → Properties → C/C++ Build → Tool Settings → MSP430 Linker → Runtime Environment → Set C System Stack Size). Stack size is defined to extend from the last location of RAM for 50 to 80 bytes (i.e., the stack extends downwards through RAM for 50 to 80 bytes, depending on the RAM size of the selected device).

Note that the stack can overflow due to small size or application errors. See Section 2.2.2.1 for a method of tracking the stack size.

2.1.5 How to Generate Binary-Format Files (TI-TXT and INTEL-HEX)

The CCE installation includes the hex430.exe conversion tool. It can be configured to generate output objects in TI-TXT format for use with the MSP-GANG430 and MSP-PRGS430 programmers, as well as INTEL-HEX format files for TI factory device programming. The tool can be used either standalone in a command line (located in <Installation Root>\Tools\compiler\msp430\bin) or directly within CCE. In the latter case, a post-build step can be configured to generate the file automatically after every build by selecting predefined formats such as TI-TXT and INTEL-HEX in the "Apply Predefined Step" menu (Project → Properties → C/C++ Build → Build Steps → Post-Build Step). The generated file is stored in the <Workspace>\<Project>\Debug\ directory.
2.1.6 **Overview of Example Programs and Projects**

Example programs for MSP430 devices are provided in `<Installation Root>\examples\msp430`. Assembly and C sources are available in the appropriate subdirectory.

To use the examples, create a new project and add the example source file to the project by clicking Project → Add Files to Active Project. In addition, example projects corresponding to the code examples are provided in `<Installation Root>\examples\msp430\example projects`. The projects can be imported by File → Import (see Section 1.14 for more information).

2.2 **Using the Integrated Debugger**

See Appendix E for a description of FET-specific menus within CCE.

2.2.1 **Breakpoint Types**

The debugger breakpoint mechanism uses a limited number of on-chip debugging resources (specifically, N breakpoint registers, see **Table 2-1**). When N or fewer breakpoints are set, the application runs at full device speed (or "realtime"). When greater than N breakpoints are set and Use Software Breakpoints is enabled (Project → Properties → TI Debug Settings → Target → MSP430 Properties → Use Software Breakpoints), an unlimited number of software breakpoints can be set while still meeting realtime constraints.

---

**Note:** A software breakpoint replaces the instruction at the breakpoint address with a call to interrupt the code execution. Therefore, there is a small delay when setting a software breakpoint. In addition, the use of software breakpoints always requires proper termination of each debug session; otherwise, the application may not be operational standalone.

---

Both address (code) and data (value) breakpoints are supported. Data breakpoints and range breakpoints each require two MSP430 hardware breakpoints.

**Table 2-1. Device Breakpoints and Other Emulation Features**

<table>
<thead>
<tr>
<th>Device</th>
<th>4-Wire JTAG</th>
<th>2-Wire JTAG(1)</th>
<th>Breakpoints (N)</th>
<th>Range Breakpoints</th>
<th>Clock Control</th>
<th>State Sequencer</th>
<th>Trace Buffer</th>
</tr>
</thead>
<tbody>
<tr>
<td>CC430F513x</td>
<td>X</td>
<td>X</td>
<td>2</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CC430F612x</td>
<td>X</td>
<td>X</td>
<td>2</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CC430F613x</td>
<td>X</td>
<td>X</td>
<td>2</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>MSP430F11x1</td>
<td>X</td>
<td></td>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>MSP430F11x2</td>
<td>X</td>
<td></td>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>MSP430F12x</td>
<td>X</td>
<td></td>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>MSP430F12x2</td>
<td>X</td>
<td></td>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>MSP430F13x</td>
<td>X</td>
<td></td>
<td>3</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>MSP430F14x</td>
<td>X</td>
<td></td>
<td>3</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>MSP430F15x</td>
<td>X</td>
<td></td>
<td>8</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>MSP430F16x</td>
<td>X</td>
<td></td>
<td>8</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>MSP430F161x</td>
<td>X</td>
<td></td>
<td>8</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>MSP430F20xx</td>
<td>X</td>
<td></td>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>MSP430F21x1</td>
<td>X</td>
<td></td>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>MSP430F21x2</td>
<td>X</td>
<td></td>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>MSP430F22x2</td>
<td>X</td>
<td></td>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>MSP430F22x4</td>
<td>X</td>
<td></td>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>MSP430F23x</td>
<td>X</td>
<td></td>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

(1) The 2-wire JTAG debug interface is also referred to as Spy-Bi-Wire (SBW) interface. Note that this interface is supported only by the USB emulators (eZ430-xxxx and MSP-FET430UIF USB JTAG emulator) and the MSP-GANG430 production programming tool. The MSP-FET430PIF parallel port JTAG emulator does not support communication in 2-wire JTAG mode.
### Using Breakpoints

If the debugger is started with greater than \( N \) breakpoints set and software breakpoints are disabled, a message is output that informs the user that not all breakpoints can be enabled. Note that the CCE permits any number of breakpoints to be set, regardless of the Use Software Breakpoints setting of CCE. If software breakpoints are disabled, a maximum of \( N \) breakpoints can be set within the debugger.

Resetting a program requires a breakpoint, which is set on the address defined in Project → Properties → TI Debug Settings → Target → Generic → Run To.

The Run To Cursor operation temporarily requires a breakpoint.

Console I/O (CIO) functions, such as printf, require the use of a breakpoint. If these functions are compiled in, but you do not wish to use a breakpoint, disable CIO functionality by changing the option in Project → Properties → TI Debug Settings → Target → Generic → Enable CIO function use.

---

**Table 2-1. Device Breakpoints and Other Emulation Features (continued)**

<table>
<thead>
<tr>
<th>Device</th>
<th>4-Wire JTAG</th>
<th>2-Wire JTAG (1)</th>
<th>Breakpoints (N)</th>
<th>Range Breakpoints</th>
<th>Clock Control</th>
<th>State Sequencer</th>
<th>Trace Buffer</th>
</tr>
</thead>
<tbody>
<tr>
<td>MSP430F23x0</td>
<td>X</td>
<td></td>
<td>2</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>MSP430F24x</td>
<td>X</td>
<td></td>
<td>3</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>MSP430F241x</td>
<td>X</td>
<td></td>
<td>8</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>MSP430F2410</td>
<td>X</td>
<td></td>
<td>3</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>MSP430F261x</td>
<td>X</td>
<td></td>
<td>8</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>MSP430F41x</td>
<td>X</td>
<td></td>
<td>2</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>MSP430F41x2</td>
<td>X X</td>
<td></td>
<td>2</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>MSP430F42x</td>
<td>X</td>
<td></td>
<td>2</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>MSP430FE42x</td>
<td>X</td>
<td></td>
<td>2</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>MSP430FE42x2</td>
<td>X</td>
<td></td>
<td>2</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>MSP430FW42x</td>
<td>X</td>
<td></td>
<td>2</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>MSP430F42x0</td>
<td>X</td>
<td></td>
<td>2</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>MSP430FG42x0</td>
<td>X</td>
<td></td>
<td>2</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>MSP430F43x</td>
<td>X</td>
<td></td>
<td>8</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>MSP430FG43x</td>
<td>X</td>
<td></td>
<td>2</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>MSP430F43x1</td>
<td>X</td>
<td></td>
<td>2</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>MSP430F44x</td>
<td>X</td>
<td></td>
<td>8</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>MSP430FG461x</td>
<td>X</td>
<td></td>
<td>8</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>MSP430F47x</td>
<td>X</td>
<td></td>
<td>2</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>MSP430F47x3</td>
<td>X</td>
<td></td>
<td>2</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>MSP430F47x4</td>
<td>X</td>
<td></td>
<td>2</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>MSP430F471xx</td>
<td>X</td>
<td></td>
<td>8</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>MSP430F54xx</td>
<td>X X</td>
<td></td>
<td>8</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
</tbody>
</table>
2.2.2.1 Breakpoints in CCE v3.1

CCE supports a number of predefined breakpoint types that can be selected by opening a menu found next to the Breakpoints icon in the Breakpoint window (Window → Show View → Other... → Debug → Breakpoints). In addition to traditional breakpoints, CCE allows setting watchpoints to break on a data address access instead of an address access. The properties of breakpoints/watchpoints can be changed in the debugger by right clicking on the breakpoint and selecting Properties.

- **Break in program range**
  Stops code execution when the program attempts to execute code in a specific range.

- **Break before program address**
  Stops code execution when the program attempts to execute code before a specific address.

- **Break after program address**
  Stops code execution when the program attempts to execute code after a specific address.

- **Break on DMA transfer**
  Breaks when a DMA access within a specified address range occurs.

- **Break on stack overflow**
  It is possible to debug the applications that caused the stack overflow. Set Break on Stack Overflow (right click in debug window and then select "Break on Stack Overflow" in the context menu). The program execution stops on the instruction that caused the stack overflow. The size of the stack can be adjusted in Project → Properties → C/C++ Build → MSP430 Executable Linker → General Options.

- **Hardware breakpoint**
  Forces a hardware breakpoint if software breakpoints are not disabled.

- **Watchpoint on data address range**
  Stops code execution when data access to an address in a specific range occurs.

- **Watchpoint with data**
  Stops code execution if a specific data access to a specific address is made with a specific value.

Restriction 1: Watchpoints are applicable to global variables and non-register local variables. In the latter case, set a breakpoint (BP) to halt execution in the function where observation of the variable is desired (set code BP there). Then set the watchpoint and delete (or disable) the code breakpoint in the function and run/restart the application.

Restriction 2: Watchpoints are applicable to variables 8 bits and 16 bits wide.

---

**Note:** Not all options are available on every MSP430 derivative (see Table 2-1). Therefore, the number of predefined breakpoint types in the breakpoint menu varies depending on the selected device.

For more information on advanced debugging with CCE, see the application report *Advanced Debugging Using the Enhanced Emulation Module (EEM) With CCE Version 3* (SLAA393).
Design Considerations for In-Circuit Programming

This chapter presents signal requirements for in-circuit programming of the MSP430.

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>3.1 Signal Connections for In-System Programming and Debugging, MSP-FET430PIF, MSP-FET430UIF, MSP-GANG430, MSP-PRGS430</td>
<td>26</td>
</tr>
<tr>
<td>3.2 External Power</td>
<td>28</td>
</tr>
<tr>
<td>3.3 Bootstrap Loader</td>
<td>29</td>
</tr>
</tbody>
</table>
3.1 Signal Connections for In-System Programming and Debugging, MSP-FET430PIF, MSP-FET430UIF, MSP-GANG430, MSP-PRGS430

With the proper connections, the debugger and an FET hardware JTAG interface (such as the MSP-FET430PIF and MSP-FET430UIF) can be used to program and debug code on the target board. In addition, the connections also support the MSP-GANG430 or MSP-PRGS430 production programmers, thus providing an easy way to program prototype boards, if desired.

Figure 3-1 shows the connections between the 14-pin FET interface module connector and the target device required to support in-system programming and debugging for 4-wire JTAG communication. Figure 3-2 shows the connections for 2-wire JTAG mode (Spy-Bi-Wire). While 4-wire JTAG mode is supported on all MSP430 devices, 2-wire JTAG mode is available on selected devices only. See Table 2-1 for information on which interface method can be used on which device.

The connections for the FET interface module and the MSP-GANG430 or MSP-PRGS430 are identical. Both the FET interface module and MSP-GANG430 can supply $V_{CC}$ to the target board (via pin 2). In addition, the FET interface module and MSP-GANG430 have a $V_{CC}$-sense feature that, if used, requires an alternate connection (pin 4 instead of pin 2). The $V_{CC}$-sense feature senses the local $V_{CC}$ present on the target board (i.e., a battery or other local power supply) and adjusts the output signals accordingly. If the target board is to be powered by a local $V_{CC}$, then the connection to pin 4 on the JTAG should be made, and not the connection to pin 2. This utilizes the $V_{CC}$-sense feature and prevents any contention that might occur if the local on-board $V_{CC}$ were connected to the $V_{CC}$ supplied from the FET interface module or the MSP-GANG430. If the $V_{CC}$-sense feature is not necessary (i.e., the target board is to be powered from the FET interface module or the GANG430) the $V_{CC}$ connection is made to pin 2 on the JTAG header and no connection is made to pin 4. Figure 3-1 and Figure 3-2 show a jumper block that supports both scenarios of supplying $V_{CC}$ to the target board. If this flexibility is not required, the desired $V_{CC}$ connections may be hard-wired eliminating the jumper block. Pins 2 and 4 must not be connected simultaneously.

Note that in 4-wire JTAG communication mode (see Figure 3-1), the connection of the target RST signal to the JTAG connector is optional when using devices that support only 4-wire JTAG communication mode. However, when using devices that support 2-wire JTAG communication mode in 4-wire JTAG mode, the RST connection must be made. The MSP430 development tools and device programmers perform a target reset by issuing a JTAG command to gain control over the device. However, if this is unsuccessful, the RST signal of the JTAG connector may be used by the development tool or device programmer as an additional way to assert a device reset.
A Make either connection J1 in case a local target power supply is used or connection J2 to power target from the debug/programming adapter.

B The RST/NMI pin R1/C1 configuration is device family dependent. See the respective MSP430 family user's guide for the recommended configuration.

C The TEST pin is available only on MSP430 family members with multiplexed JTAG pins. See the device-specific data sheet to determine if this pin is available.

D The connection to the JTAG connector RST pin is optional when using 4-wire JTAG communication mode capable-only devices and not required for device programming or debugging. However, this connection is required when using 2-wire JTAG communication mode capable devices in 4-wire JTAG mode.

E When using 2-wire JTAG communication capable devices in 4-wire JTAG mode, the upper limit for C1 should not exceed 2.2 nF. This applies to both TI FET interface modules (LPT/USB FET).

Figure 3-1. Signal Connections for 4-Wire JTAG Communication
A  Make either connection J1 in case a local target power supply is used or connection J2 to power target from the debug/programming adapter.

B  The device RST/NMI/SBWTDIO pin is used in 2-wire mode for bidirectional communication with the device during JTAG access and that any capacitance attached to this signal may affect the ability to establish a connection with the device. The upper limit for C1 is 2.2 nF when using current TI FET interface modules (USB FET).

C  R2 is used to protect the JTAG debug interface TCK signal against the JTAG security fuse blow voltage that is supplied by the TEST pin during the fuse blow process. If fuse blow functionality is not needed, R2 is not required (becomes 0 Ω), and the connection TEST must not be made.

Figure 3-2. Signal Connections for 2-Wire JTAG Communication (Spy-Bi-Wire)

3.2 External Power

The PC parallel port can source a limited amount of current. Because of the ultra-low-power requirement of the MSP430, a standalone FET does not exceed the available current. However, if additional circuitry is added to the tool, this current limit could be exceeded. In this case, external power can be supplied to the tool via connections provided on the target socket modules. See the schematics and pictorials of the target socket modules in Appendix B to locate the external power connectors.

The MSP-FET430UIF can supply targets with up to 100 mA through pin 2 of the 14-pin connector. \( V_{CC} \) for the target can be selected between 1.8 V and 5 V in steps of 0.1 V. Alternatively, the target can be supplied externally. In this case, the external voltage should be connected to pin 4 of the 14-pin connector. The MSP-FET430UIF then adjusts the level of the JTAG signals to external \( V_{CC} \) automatically. Only pin 2 (MSP-FET430UIF supplies target) or pin 4 (target is externally supplied) must be connected; not both at the same time.

When a target socket module is powered from an external supply, the external supply powers the device on the target socket module and any user circuitry connected to the target socket module, and the FET interface module continues to be powered from the PC via the parallel port. If the externally supplied voltage differs from that of the FET interface module, the target socket module must be modified so that the externally supplied voltage is routed to the FET interface module (so that it may adjust its output voltage levels accordingly). See the target socket module schematics in Appendix B.
3.3 Bootstrap Loader

The JTAG pins provide access to the flash memory of the MSP430Fxxx devices. On some devices, these pins are shared with the device port pins, and this sharing of pins can complicate a design (or sharing may not be possible). As an alternative to using the JTAG pins, most MSP430Fxxx devices contain a program (a "bootstrap loader") that permits the flash memory to be erased and programmed using a reduced set of signals. The *MSP430 Memory Programming User's Guide* (SLAU265) describes this interface. TI does not produce a BSL tool. However, customers can easily develop their own BSL tools using the information in the application reports, or BSL tools can be purchased from third parties. See the [MSP430 web site](http://www.ti.com) for the application reports and a list of MSP430 third-party tool developers.

TI suggests that MSP430Fxxx customers design their circuits with the BSL in mind (i.e., TI suggests providing access to these signals via, for example, a header).

See FAQ Hardware #12 for a second alternative to sharing the JTAG and port pins.
Frequently Asked Questions

This appendix presents solutions to frequently asked questions regarding hardware, program development, and debugging tools.

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>A.1 Hardware</td>
<td>32</td>
</tr>
<tr>
<td>A.2 Program Development (Assembler, C-Compiler, Linker, IDE)</td>
<td>33</td>
</tr>
<tr>
<td>A.3 Debugging</td>
<td>34</td>
</tr>
</tbody>
</table>
A.1 Hardware

1. **The state of the device** (CPU registers, RAM memory, etc.) is **undefined following a reset.** Exceptions to the above statement are that the PC is loaded with the word at 0xFFFE (i.e., the reset vector), the status register is cleared, and the peripheral registers (SFRs) are initialized as documented in the device family user's guides. The CCE debugger resets the device after programming it.

2. **MSP430F22xx Target Socket Module (MSP-TS430DA38) – Important Information**

   Due to the large capacitive coupling introduced by the device socket between the adjacent signals XIN/P2.6 (socket pin 6) and RST/SBWTDIO (socket pin 7), in-system debugging can disturb the LFXT1 low-frequency crystal oscillator operation (ACLK). This behavior applies only to the Spy-Bi-Wire (2-wire) JTAG configuration and only to the period while a debug session is active.

   **Workarounds:**
   - Use the 4-wire JTAG mode debug configuration instead of the Spy-Bi-Wire (2-wire) JTAG configuration. This can be achieved by placing jumpers JP4 through JP9 accordingly.
   - Use the debugger option "Run Free" that can be selected from the Advanced Run dropdown menu (at top of Debug View). This prevents the debugger from accessing the MSP430 while the application is running. Note that, in this mode, a manual halt is required to see if a breakpoint was hit. See the IDE documentation for more information on this feature.
   - Use an external clock source to drive XIN directly.

3. The 14-conductor **cable** connecting the FET interface module and the target socket module **must not exceed 8 inches (20 centimeters) in length.**

4. The signal assignment on the **14-conductor cable** is **identical** for the parallel port interface and the USB FET.

5. **To utilize the on-chip ADC voltage references, C6 (10 µF, 6.3 V, low leakage) must be installed** on the target socket module.

6. **To utilize the charge pump on the devices with LCD+ Module, C4 (10 µF, low leakage) must be installed** on the target socket module.

7. **Crystals/resonators Q1 and Q2 (if applicable) are not provided on the target socket module.** For MSP430 devices that contain user-selectable loading capacitors, the effective capacitance is the selected capacitance plus 3 pF (pad capacitance) divided by two.

8. **Crystals/resonators have no effect upon the operation of the tool and the CCE debugger** (as any required clocking/timing is derived from the internal DCO/FLL).

9. **On 20-pin and 28-pin devices** with multiplexed port/JTAG pins (P1.4 to P1.7), "Run Free" (in Advanced Run menu at top of Debug View) **must be selected to use these pins in their port capacity.**

10. **As an alternative to sharing the JTAG and port pins** (on 20 and 28 pin devices), **consider using an MSP430 device that is a "superset" of the smaller device.** A very powerful feature of the MSP430 is that the family members are code and architecturally compatible, so code developed on one device (e.g., one without shared JTAG and port pins) port effortlessly to another (assuming an equivalent set of peripherals).

11. **Information memory may not be blank** (erased to 0xFF) when the device is delivered from TI. Customers should erase the Information Memory before its first usage. Main Memory of packaged devices is blank when the device is delivered from TI.

12. **The device current increases by approximately 10 µA when a device in low-power mode is stopped** (using Halt) and then the low-power mode is **restored** (using Run). This behavior appears to happen on all devices except the MSP430F12x.
13. The following ZIF sockets are used in the FET tools and target socket modules:

- 14-pin device (PW package): Enplas OTS-14-065-01
- 28-pin device (DW package): Wells-CTI 652 D028
- 28-pin device (PW package): Enplas OTS-28-0.65-01
- 38-pin device (DA package): Yamaichi IC189-0382-037
- 40-pin device (RHA package): Enplas QFN-40B-0.5-01
- 48-pin device (DL package): Yamaichi IC51-0482-1163
- 64-pin device (PM package): Yamaichi IC51-0644-807
- 80-pin device (PN package): Yamaichi IC201-0804-014
- 100-pin device (PZ package): Yamaichi IC201-1004-008

Enplas: [www.enplas.com](http://www.enplas.com)
Wells-CTI: [www.wellscti.com](http://www.wellscti.com)
Yamaichi: [www.yamaichi.us](http://www.yamaichi.us)

A.2 Program Development (Assembler, C-Compiler, Linker, IDE)

**Note:** Consider the CCE Release Notes

For the case of unexpected behavior, see the CCE Release Notes document for known bugs and limitations of the current CCE version. This information can be accessed through the menu item Start → All Programs → Texas Instruments → Code Composer Essentials v3.1 → Release Notes.

1. **A common MSP430 "mistake" is to fail to disable the watchdog mechanism:** the watchdog is enabled by default, and it resets the device if not disabled or properly managed by the application.
2. **Within the C libraries, GIE (Global Interrupt Enable) is disabled before** (and restored after) the hardware multiplier is used.
3. **It is possible to mix assembly and C programs within CCE.** See the "Interfacing C/C++ With Assembly Language" chapter of the *MSP430 Optimizing C/C++ Compiler User's Guide* (literature number SLAU132).
4. **Constant definitions (#define) used within the .h files are effectively reserved** and include, for example, C, Z, N, and V. Do not create program variables with these names.
5. **Compiler optimization can remove unused variables and/or statements that have no effect** and can affect debugging. To prevent this, these variables can be declared volatile; e.g., volatile int i;.
A.3 Debugging

The debugger is part of CCE and can be used as a standalone application. This section is applicable when using the debugger both standalone and from the CCE IDE.

**Note:** Consider the CCE release notes

In case of unexpected behavior, see the CCE Release Notes document for known bugs and limitations of the current CCE version. To access this information, click Start → All Programs → Texas Instruments → Code Composer Essentials v3.1 → Release Notes.

1. **The debugger reports that it cannot communicate with the device.** Possible solutions to this problem include:
   - Ensure that the correct port has been selected in the TI Debug Settings (Project → Properties → TI Debug Settings → Setup → Connection).
   - Ensure that the jumper settings are configured correctly on the target hardware.
   - Ensure that no other software application (e.g., printer drivers, etc.) has reserved or taken control of the COM/parallel port, which would prevent the debug server from communicating with the device.
   - Open the Device Manager and determine if the driver for the FET tool has been correctly installed and if the COM/parallel port is successfully recognized by the Windows OS. Check the PC BIOS for the parallel port settings (see FAQ Debugging #5). For users of IBM or Lenovo ThinkPad® computers, try port setting LPT2 and LPT3, even if operating system reports that the parallel port is located at LPT1.
   - Restart the computer.

Ensure that the MSP430 device is securely seated in the socket (so that the “fingers” of the socket completely engage the pins of the device), and that its pin 1 (indicated with a circular indentation on the top surface) aligns with the "1" mark on the PCB.

**CAUTION**

**Possible Damage To Device**

Always handle MSP430 devices with a vacuum pick-up tool only; do not use your fingers, as you can easily bend the device pins and render the device useless. Also, always observe and follow proper ESD precautions.

2. **The debugger can debug applications that utilize interrupts and low-power modes.** See FAQ Debugging #17.

3. **The debugger cannot access the device registers and memory while the device is running.** The user must stop the device to access device registers and memory.

4. **The debugger reports that the device JTAG security fuse is blown.** With current MSP-FET430PIF and MSP430-FET430UIF JTAG interface tools, there is a weakness when adapting target boards that are powered externally. This leads to an accidental fuse check in the MSP430 and results in the JTAG security fuse being recognized as blown although it is not. This occurs for MSP-FET430PIF and MSP-FET430UIF but is mainly seen on MSP-FET430UIF.

   **Workarounds:**
   - Connect the device RST/NMI pin to JTAG header (pin 11), MSP-FET430PIF/MSP-FET430UIF interface tools are able to pull the RST line, this also resets the device internal fuse logic.
   - Do not connect both VCC Tool (pin 2) and VCC Target (pin 4) of the JTAG header. Specify a value for VCC in the debugger that is equal to the external supply voltage.

5. **The parallel port designators (LPTx) have the following physical addresses:** LPT1 = 378h, LPT2 = 278h, LPT3 = 3BCh. The configuration of the parallel port (ECP, Compatible, Bidirectional, Normal) is not significant; ECP seems to work well. See FAQ Debugging #1 for additional hints on solving communication problems between the debugger and the device.
6. The debugger asserts \( \text{RST}/\text{NMI} \) to reset the device when the debugger is started and when the device is programmed. The device is also reset by the debugger Reset button, and when the device is manually reprogrammed (using Reload), and when the JTAG is resynchronized (using Resynchronize JTAG). When \( \text{RST}/\text{NMI} \) is not asserted (low), the debugger sets the logic driving \( \text{RST}/\text{NMI} \) to high impedance, and \( \text{RST}/\text{NMI} \) is pulled high via a resistor on the PCB. \( \text{RST}/\text{NMI} \) is asserted and negated after power is applied when the debugger is started. \( \text{RST}/\text{NMI} \) is then asserted and negated a second time after device initialization is complete.

7. The debugger can debug a device whose program reconfigures the function of the \( \text{RST}/\text{NMI} \) pin to NMI.

8. The level of the XOUT/TCLK pin is undefined when the debugger resets the device. The logic driving XOUT/TCLK is set to high impedance at all other times.

9. When making current measurements of the device, ensure that the JTAG control signals are released, otherwise the device is powered by the signals on the JTAG pins and the measurements are erroneous. See FAQs Debugging #10 and Hardware #12.

10. When the debugger has control of the device, the CPU is on (i.e., it is not in low-power mode) regardless of the settings of the low-power mode bits in the status register. Any low-power mode condition is restored prior to STEP or GO. Consequently, do not measure the power consumed by the device while the debugger has control of the device. Instead, run the application using Release JTAG on run.

11. The MEMORY window correctly displays the contents of memory where it is present. However, the MEMORY window incorrectly displays the contents of memory where there is none present. Memory should be used only in the address ranges as specified by the device data sheet.

12. The debugger utilizes the system clock to control the device during debugging. Therefore, device counters and other components that are clocked by the Main System Clock (MCLK) are affected when the debugger has control of the device. Special precautions are taken to minimize the effect upon the watchdog timer. The CPU core registers are preserved. All other clock sources (SMCLK and ACLK) and peripherals continue to operate normally during emulation. In other words, the Flash Emulation Tool is a partially intrusive tool.

   Devices that support clock control can further minimize these effects by stopping the clock(s) during debugging (Project → Properties → TI Debug Settings → Target → MSP430 Properties → Clock Control).

13. When programming the flash, do not set a breakpoint on the instruction immediately following the write to flash operation. A simple work-around to this limitation is to follow the write to flash operation with a NOP and not to set a breakpoint on the instruction following the NOP.

14. Multiple internal machine cycles are required to clear and program the flash memory. When single stepping over instructions that manipulate the flash, control is given back to the debugger before these operations are complete. Consequently, the debugger updates its memory window with erroneous information. A workaround for this behavior is to follow the flash access instruction with a NOP and then step past the NOP before reviewing the effects of the flash access instruction.

15. Bits that are cleared when read during normal program execution (i.e., interrupt flags) are cleared when read while being debugged (i.e., memory dump, peripheral registers).

   Using certain MSP430 devices with enhanced emulation logic such as MSP430F43x/44x devices, bits do not behave this way (i.e., the bits are not cleared by the debugger read operations).

16. The debugger cannot be used to debug programs that execute in the RAM of F12x and F41x devices. A workaround for this limitation is to debug programs in flash.

17. While single stepping with active and enabled interrupts, it can appear that only the interrupt service routine (ISR) is active (i.e., the non-ISR code never appears to execute, and the single step operation stops on the first line of the ISR). However, this behavior is correct because the device processes an active and enabled interrupt before processing non-ISR (i.e., mainline) code. A workaround for this behavior is, while within the ISR, to disable the GIE bit on the stack, so that interrupts are disabled after exiting the ISR. This permits the non-ISR code to be debugged (but without interrupts). Interrupts can later be re-enabled by setting GIE in the status register in the Register window.

   On devices with Clock Control, it may be possible to suspend a clock between single steps and delay an interrupt request (Project → Properties → TI Debug Settings → Target → MSP430 Properties → Clock Control).
18. On devices equipped with a Data Transfer Controller (DTC), the completion of a data transfer cycle preempts a single step of a low-power mode instruction. The device advances beyond the low-power mode instruction only after an interrupt is processed. Until an interrupt is processed, it appears that the single step has no effect. A workaround to this situation is to set a breakpoint on the instruction following the low-power mode instruction, and then execute (Run) to this breakpoint.

19. The transfer of data by the Data Transfer Controller (DTC) may not stop precisely when the DTC is stopped in response to a single step or a breakpoint. When the DTC is enabled and a single step is performed, one or more bytes of data can be transferred. When the DTC is enabled and configured for two-block transfer mode, the DTC may not stop precisely on a block boundary when stopped in response to a single step or a breakpoint.

20. Breakpoints. CCE supports a number of predefined breakpoint and watchpoint types. See Section 2.2.2 for a detailed overview.
This appendix contains information relating to the FET hardware, including schematics and PCB pictorials. All other tools, such as the eZ430 series, are described in separate product-specific user's guides.

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>B.1 Schematics and PCBs</td>
<td>38</td>
</tr>
<tr>
<td>B.2 MSP-FET430UIF Revision History</td>
<td>67</td>
</tr>
</tbody>
</table>
B.1 Schematics and PCBs

Figure B-1. MSP-TS430PW14 Target Socket Module, Schematic
Figure B-2. MSP-TS430PW14 Target Socket Module, PCB
Figure B-3. MSP-TS430DW28 Target Socket Module, Schematic
Jumper J4
Open to disconnect LED
Orient Pin 1 of MSP430 device
Jumper J5
Open to measure current
Connector J3
External power connector
Remove R8 and jumper R9
LED connected to P1.0

Figure B-4. MSP-TS430DW28 Target Socket Module, PCB
Figure B-5. MSP-TS430PW28 Target Socket Module, Schematic
Figure B-6. MSP-TS430PW28 Target Socket Module, PCB
Figure B-7. MSP-TS430DA38 Target Socket Module, Schematic
Orient pin 1 of MSP430 device
LED connected to P1.0
Connector J3
External power connector
Jumper JP1 to 'ext'
Jumper JP3
Open to disconnect LED
Jumper JP2
Open to measure current
Connector J3
External power connector
Jumper JP1 to 'ext'

Jumpers JP4 to JP6
Close 1-2 to debug in Spy-Bi-Wire Mode,
Close 2-3 to debug in 4-wire JTAG Mode

Figure B-8. MSP-TS430DA38 Target Socket Module, PCB
Figure B-9. MSP-TS430QFN23x0 Target Socket Module, Schematic
Figure B-10. MSP-TS430QFN23x0 Target Socket Module, PCB
Figure B-11. MSP-TS430DL48 Target Socket Module, Schematic
Jumper J4
Open to disconnect LED
LED connected to P1.0
Orient pin 1 of MSP430 device

Jumper J5
Open to measure current
Connector J3
External power connector
Jumper JP1 to ‘ext’

Figure B-12. MSP-TS430DL48 Target Socket Module, PCB
NOTE: Connections between the JTAG header and pins XOUT and XIN are no longer required and should not be made.

Figure B-13. MSP-TS430PM64 Target Socket Module, Schematic
Connector J5
External power connection
Remove R8 and jumper R9

LED connected to pin 12
Jumper J7
Open to measure current
Jumper J6
Open to disconnect LED
Orient Pin 1 of MSP430 device

Figure B-14. MSP-TS430PM64 Target Socket Module, PCB
NOTE: For MSP430F(G)47x derivatives:
Connect pins 7 and 10 (GND) externally to DVSS (see data sheet).
Connect load capacitance on Vref pin 60 when SD16 is used (see data sheet).

**Figure B-15. MSP-TS430PN80 Target Socket Module, Schematic**
Connector J5
External power connection
Remove R8 and jumper R9
LED connected to pin 12
Jumper J6
Open to disconnect LED
Orient Pin 1 of MSP430 device

Figure B-16. MSP-TS430PN80 Target Socket Module, PCB
NOTE: Connections between the JTAG header and pins XOUT and XIN are no longer required and should not be made.

Figure B-17. MSP-TS430PZ100 Target Socket Module, Schematic
LED connected to pin 12
Connector J5
External power connection
Remove R8 and jumper R9

Orient Pin 1 of MSP430 device

Jumper J6
Open to disconnect LED

Jumper J7
Open to measure current

Figure B-18. MSP-TS430PZ100 Target Socket Module, PCB
Figure B-19. MSP-TS430PZ100A Target Socket Module, Schematic
Figure B-20. MSP-TS430PZ100A Target Socket Module, PCB
Figure B-21. MSP-TS430PZ5x100 Target Socket Module, Schematic
Jumpers JP5 to JP10
Close 1-2 to debug in Spy-Bi-Wire mode.
Close 2-3 to debug in 4-wire JTAG mode.

Connector J5
External power connector
Jumper J3 to ‘ext’

Jumper JP1
Open to measure current

Jumper JP2
Open to disconnect LED

LED connected to P1.0

Jumper JP3
1-2 (int): Power supply via JTAG debug interface
2-3 (ext): External power supply

Figure B-22. MSP-TS430PZ5x100 Target Socket Module, PCB
Figure B-23. MSP-FET430PIF FET Interface Module, Schematic
Figure B-24. MSP-FET430PIF FET Interface Module, PCB
Figure B-25. MSP-FET430UIF USB Interface, Schematic (1 of 4)
Figure B-26. MSP-FET430UIF USB Interface, Schematic (2 of 4)
Figure B-27. MSP-FET430UIF USB Interface, Schematic (3 of 4)
Figure B-28. MSP-FET430UIF USB Interface, Schematic (4 of 4)
Figure B-29. MSP-FET430UIF USB Interface, PCB
B.2 MSP-FET430UIF Revision History

Revision 1.3
• Initial released hardware version

Assembly change on 1.3 (May 2005)
• R29, R51, R42, R21, R22, R74: value changed from 330R to 100R

Changes 1.3 to 1.4 (Aug 2005)
• J5: VBUS and RESET additionally connected
• R29, R51, R42, R21, R22, R74: value changed from 330R to 100R
• U1, U7: F1612 can reset TUSB3410; R44 = 0R added
• TARGET-CON.: pins 6, 10, 12, 13, 14 disconnected from GND
• Firmware-upgrade option through BSL: R49, R52, R53, R54 added; R49, R52 are currently DNP
• Pullups on TCK and TMS: R78, R79 added
• U2: Changed from SN75LVC1G125DBV to SN75LVC1G07DBV

Note: Using a locally powered target board with hardware revision 1.4

Using an MSP-FET430UIF interface hardware revision 1.4 with populated R62 in conjunction with a locally powered target board is not possible. In this case, the target device RESET signal is pulled down by the FET tool. It is recommended to remove R62 to eliminate this restriction. This component is located close to the 14-pin connector on the MSP-FET430UIF PCB. See the schematic and PCB drawings in this document for the exact location of this component.

Assembly change on 1.4 (January 2006)
• R62: not populated
Source code for the TI CCE C compiler and source code for the IAR Embedded Workbench compiler are not 100% compatible. While the standard ANSI/ISO C code is portable among these tools, implementation-specific extensions differ and need to be ported. This appendix documents the major differences between the two compilers.

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>C.1 Interrupt Vector Definition</td>
<td>70</td>
</tr>
<tr>
<td>C.2 Intrinsic Functions</td>
<td>70</td>
</tr>
<tr>
<td>C.3 Data and Function Placement</td>
<td>70</td>
</tr>
<tr>
<td>C.4 C Calling Conventions</td>
<td>72</td>
</tr>
<tr>
<td>C.5 Other Differences</td>
<td>72</td>
</tr>
</tbody>
</table>
C.1 Interrupt Vector Definition

IAR ISR declarations (using the #pragma vector = ) are now fully supported in CCE. However, this is not the case for all other IAR pragma directives.

C.2 Intrinsic Functions

CCE and IAR tools use the same instructions for MSP430 processor-specific intrinsic functions.

C.3 Data and Function Placement

C.3.1 Data Placement at an Absolute Location

The scheme implemented in the IAR compiler using either the @ operator or the #pragma location directive is not supported with the CCE compiler:

/* IAR C Code */
__no_init char alpha @ 0x0200; /* Place 'alpha' at address 0x200 */
#pragma location = 0x0202
const int beta;

If absolute data placement is needed, this can be achieved with entries into the linker command file, and then declaring the variables as extern in the C code:

/* CCE Linker Command File Entry */
alpha = 0x200;
beta = 0x202;
/* CCE C Code */
extern char alpha;
extern int beta;

The absolute RAM locations must be excluded from the RAM segment; otherwise, their content may be overwritten as the linker dynamically allocates addresses. The start address and length of the RAM block must be modified within the linker command file. For the previous example, the RAM start address must be shifted 4 bytes from 0x0200 to 0x0204, which reduces the length from 0x0080 to 0x007C (for an MSP430 device with 128 bytes of RAM):

/* CCE Linker Command File Entry */

*******************************************************************************/
/* SPECIFY THE SYSTEM MEMORY MAP */
*******************************************************************************

MEMORY /* assuming a device with 128 bytes of RAM */
{
... RAM :origin = 0x0204, length = 0x007C /* was: origin = 0x200, length = 0x0080 */
...}

The definitions of the peripheral register map in the linker command files (lnk_msp430xxxx.cmd) and the device-specific header files (msp430xxxx.h) that are supplied with CCE are an example of placing data at absolute locations.

---

**Note:** When a project is created, CCE copies the linker command file corresponding to the selected MSP430 derivative from the include directory (<Installation Root\>tools\compiler\MSP430\include) into the project directory. Therefore, ensure that all linker command file changes are done in the project directory. This allows the use of project-specific linker command files for different projects using the same device.
### C.3.2 Data Placement Into Named Segments

In IAR, it is possible to place variables into named segments using either the @ operator or a #pragma directive:

```c
/* IAR C Code */
__no_init int alpha @ "MYSEGMENT";  /* Place 'alpha' into 'MYSEGMENT' */
#pragma location="MYSEGMENT"  /* Place 'beta' into 'MYSEGMENT' */
const int beta;
```

With the CCE compiler, the #pragma DATA_SECTION() directive must be used:

```c
/* CCE C Code */
#pragma DATA_SECTION(alpha, "MYSEGMENT")
int alpha;
#pragma DATA_SECTION(beta, "MYSEGMENT")
const int beta;
```

See Section C.5.3 for information on how to translate memory segment names between IAR and CCE.

### C.3.3 Function Placement Into Named Segments

With the IAR compiler, functions can be placed into a named segment using the @ operator or the #pragma location directive:

```c
/* IAR C Code */
void g(void) @ "MYSEGMENT" {
}
#pragma location="MYSEGMENT"
void h(void) {
}
```

With the CCE compiler, the following scheme with the #pragma CODE_SECTION() directive must be used:

```c
/* CCE C Code */
#pragma CODE_SECTION(g, "MYSEGMENT")
void g(void) {
}
```

See Section C.5.3 for information on how to translate memory segment names between IAR and CCE.
C.4 C Calling Conventions

The CCE and IAR C-compilers use different calling conventions for passing parameters to functions. When porting a mixed C and assembly project to the TI CCE code generation tools, the assembly functions need to be modified to reflect these changes. For detailed information about the calling conventions, see the TI MSP430 Optimizing C/C++ Compiler User's Guide (SLAU132) and the IAR MSP430 C/C++ Compiler Reference Guide.

The following example is a function that writes the 32-bit word 'Data' to a given memory location in big-endian byte order. It can be seen that the parameter 'Data' is passed using different CPU registers.

IAR Version:

```c
void WriteDWEBE(unsigned char *Add, unsigned long Data)
{
    ; Writes a DWORD to the given memory location in big-endian format. The
    ; memory address MUST be word-aligned.
    ;
    ; IN: R12 Address (Add)
    ; R14 Lower Word (Data)
    ; R15 Upper Word (Data)
    
    WriteDWEBE
        swpb R14 ; Swap bytes in lower word
        swpb R15 ; Swap bytes in upper word
        mov.w R15,0(R12) ; Write 1st word to memory
        mov.w R14,2(R12) ; Write 2nd word to memory
        ret
}
```

CCE Version:

```c
void WriteDWEBE(unsigned char *Add, unsigned long Data)
{
    ; Writes a DWORD to the given memory location in big-endian format. The
    ; memory address MUST be word-aligned.
    ;
    ; IN: R12 Address (Add)
    ; R13 Lower Word (Data)
    ; R14 Upper Word (Data)
    
    WriteDWEBE
        swpb R13 ; Swap bytes in lower word
        swpb R14 ; Swap bytes in upper word
        mov.w R14,0(R12) ; Write 1st word to memory
        mov.w R13,2(R12) ; Write 2nd word to memory
        ret
}
```

C.5 Other Differences

C.5.1 Initializing Static and Global Variables

The ANSI/ISO C standard specifies that static and global (extern) variables without explicit initializations must be pre-initialized to 0 (before the program begins running). This task is typically performed when the program is loaded and is implemented in the IAR compiler:

```c
/* IAR, global variable, initialized to 0 upon program start */
int Counter;
```

However, the TI CCE compiler does not pre-initialize these variables; therefore, it is up to the application to fulfill this requirement:

```c
/* CCE, global variable, manually zero-initialized */
int Counter = 0;
```
### C.5.2 Custom Boot Routine

With the IAR compiler, the C startup function can be customized, giving the application a chance to perform early initializations such as configuring peripherals, or omit data segment initialization. This is achieved by providing a customized `__low_level_init()` function:

```c
/* IAR C Code */
int __low_level_init(void)
{
    /* Insert your low-level initializations here */
    /*==================================*/
    /* Choose if segment initialization */
    /* should be done or not. */
    /* Return: 0 to omit initialization */
    /* 1 to run initialization */
    /*==================================*/
    return (1);
}
```

The return value controls whether or not data segments are initialized by the C startup code. With the CCE C compiler, the custom boot routine name is `_system_pre_init()`. It is used the same way as in the IAR compiler.

```c
/* CCE C Code */
int _system_pre_init(void)
{
    /* Insert your low-level initializations here */
    /*==================================*/
    /* Choose if segment initialization */
    /* should be done or not. */
    /* Return: 0 to omit initialization */
    /* 1 to run initialization */
    /*==================================*/
    return (1);
}
```

Note that omitting segment initialization with both compilers omits both explicit and non-explicit initialization. The user must ensure that important variables are initialized at run time before they are used.

### C.5.3 Predefined Memory Segment Names

Memory segment names for data and function placement are controlled by device-specific linker command files in both CCE and IAR tools. However, different segment names are used. See the linker command files for more detailed information. The following table shows how to convert the most commonly used segment names.

<table>
<thead>
<tr>
<th>Description</th>
<th>CCE Segment Name</th>
<th>IAR Segment Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>RAM</td>
<td>.bss</td>
<td>DATA16_N</td>
</tr>
<tr>
<td></td>
<td></td>
<td>DATA16_I</td>
</tr>
<tr>
<td></td>
<td></td>
<td>DATA16_Z</td>
</tr>
<tr>
<td>Stack (RAM)</td>
<td>.stack</td>
<td>CSTACK</td>
</tr>
<tr>
<td>Main memory (flash or ROM)</td>
<td>.text</td>
<td>CODE</td>
</tr>
<tr>
<td>Information memory (flash or ROM)</td>
<td>.infoA</td>
<td>INFOA</td>
</tr>
<tr>
<td></td>
<td>.infoB</td>
<td>INFOB</td>
</tr>
<tr>
<td></td>
<td></td>
<td>INFO</td>
</tr>
<tr>
<td>Interrupt vectors (flash or ROM)</td>
<td>.int00</td>
<td>INTVEC</td>
</tr>
<tr>
<td></td>
<td>.int01</td>
<td></td>
</tr>
<tr>
<td></td>
<td>...</td>
<td></td>
</tr>
<tr>
<td></td>
<td>.int14</td>
<td></td>
</tr>
<tr>
<td>Reset vector (flash or ROM)</td>
<td>.reset</td>
<td>RESET</td>
</tr>
</tbody>
</table>
C.5.4 Predefined Macro Names

Both IAR and CCE compiler support a few non ANSI/ISO standard predefined macro names, which help creating code that can be compiled and used on different compiler platforms. Check if a macro name is defined using the #ifdef directive.

<table>
<thead>
<tr>
<th>Description</th>
<th>CCE Macro Name</th>
<th>IAR Macro Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Is MSP430 the target and is a particular compiler platform used?</td>
<td><strong>MSP430</strong></td>
<td><strong>ICC430</strong></td>
</tr>
<tr>
<td>Is a particular compiler platform used?</td>
<td><strong>TI_COMPILER_VERSION</strong></td>
<td><strong>IAR_SYSTEMS_ICC</strong></td>
</tr>
<tr>
<td>Is a C header file included from within assembly source code?</td>
<td><strong>ASM_HEADER</strong></td>
<td><strong>IAR_SYSTEMS_ASM</strong></td>
</tr>
</tbody>
</table>
Source for the TI CCE assembler and source code for the IAR assembler are not 100% compatible. The instruction mnemonics are identical, while the assembler directives are somewhat different. This appendix documents the differences between the CCE assembler directives and the IAR 2.x/3.x assembler directives.

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>D.1 Sharing C/C++ Header Files With Assembly Source</td>
<td>76</td>
</tr>
<tr>
<td>D.2 Segment Control</td>
<td>76</td>
</tr>
<tr>
<td>D.3 Translating A430 Assembler Directives to Asm430 Directives</td>
<td>77</td>
</tr>
</tbody>
</table>
D.1 Sharing C/C++ Header Files With Assembly Source

The IAR A430 assembler supports certain C/C++ preprocessor directives directly and, thereby, allows direct including of C/C++ header files such as the MSP430 device-specific header files (msp430xxxx.h) into the assembly code:

```
#include "msp430x14x.h" // Include device header file
```

With the CCE Asm430 assembler, a different scheme that uses the .cdecls directive must be used. This directive allows programmers in mixed assembly and C/C++ environments to share C/C++ headers containing declarations and prototypes between the C/C++ and assembly code:

```
.cdecls C,LIST,"msp430x14x.h" ; Include device header file
```

More information on the .cdecls directive can be found in the MSP430 Assembly Language Tools User's Guide (literature number SLAU131).

D.2 Segment Control

The CCE Asm430 assembler does not support any of the IAR A430 segment control directives such as ORG, ASEG, RSEG, and COMMON.

<table>
<thead>
<tr>
<th>Description</th>
<th>Asm430 Directive (CCE)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reserve space in the .bss uninitialized section</td>
<td>.bss</td>
</tr>
<tr>
<td>Reserve space in a named uninitialized section</td>
<td>.usect</td>
</tr>
<tr>
<td>Allocate program into the default program section (initialized)</td>
<td>.text</td>
</tr>
<tr>
<td>Allocate data into a named initialized section</td>
<td>.sect</td>
</tr>
</tbody>
</table>

To allocate code and data sections to specific addresses with the CCE assembler, it is necessary to create/use memory sections defined in the linker command files. The following example demonstrates interrupt vector assignment in both IAR and CCE assembly to highlight the differences.

```
;--------------------------------------------------------------
; Interrupt Vectors Used MSP430x11x1/12x(2) – IAR Assembler
;--------------------------------------------------------------
ORG 0FFFEh ; MSP430 RESET Vector
DW   RESET  ;
ORG 0FFF2h ; Timer_A0 Vector
DW   TA0_ISR ;

;--------------------------------------------------------------
; Interrupt Vectors Used MSP430x11x1/12x(2) – CCE Assembler
;--------------------------------------------------------------
.sect "reset" ; MSP430 RESET Vector
.short RESET ;
.sect "int09" ; Timer_A0 Vector
.short TA0_ISR ;
```

Both examples assume that the standard device support files (header files, linker command files) are used. Note that the linker command files are different between IAR and CCE and cannot be reused. See Section C.5.3 for information on how to translate memory segment names between IAR and CCE.
D.3 Translating A430 Assembler Directives to Asm430 Directives

D.3.1 Introduction

The following sections describe, in general, how to convert assembler directives for the IAR A430 assembler (A430) to Texas Instruments CCE Asm430 assembler (Asm430) directives. These sections are intended only as a guide for translation. For detailed descriptions of each directive, see either the MSP430 Assembly Language Tools User's Guide (SLAU131), from Texas Instruments, or the MSP430 IAR Assembler Reference Guide from IAR.

Note: Only the assembler directives require conversion

Only the assembler directives require conversion, not the assembler instructions. Both assemblers use the same instruction mnemonics, operands, operators, and special symbols such as the section program counter ($) and the comment delimiter (;).

The A430 assembler is not case sensitive by default. These sections show the A430 directives written in uppercase to distinguish them from the Asm430 directives, which are shown in lower case.

D.3.2 Character Strings

In addition to using different directives, each assembler uses different syntax for character strings. A430 uses C syntax for character strings: A quote is represented using the backslash character as an escape character together with quote (") and the backslash itself is represented by two consecutive backslashes (\). In Asm430 syntax, a quote is represented by two consecutive quotes (""), see examples:

<table>
<thead>
<tr>
<th>Character String</th>
<th>Asm430 Syntax (CCE)</th>
<th>A430 Syntax (IAR)</th>
</tr>
</thead>
<tbody>
<tr>
<td>PLAN &quot;C&quot;</td>
<td>&quot;PLAN &quot;&quot;C&quot;&quot;&quot;&quot;</td>
<td>&quot;PLAN &quot;C&quot;&quot;&quot;&quot;</td>
</tr>
<tr>
<td>\dos\command.com</td>
<td>&quot;\dos\command.com&quot;</td>
<td>&quot;\dos\command.com&quot;</td>
</tr>
<tr>
<td>Concatenated string (i.e. Error 41)</td>
<td>-</td>
<td>&quot;Error &quot; &quot;41&quot;</td>
</tr>
</tbody>
</table>
D.3.3 Section Control Directives

Asm430 has three predefined sections into which various parts of a program are assembled. Uninitialized data is assembled into the .bss section, initialized data into the .data section, and executable code into the .text section.

A430 also uses sections or segments, but there are no predefined segment names. Often, it is convenient to adhere to the names used by the C compiler: DATA16_Z for uninitialized data, CONST for constant (initialized) data, and CODE for executable code. The following table uses these names.

A pair of segments can be used to make initialized, modifiable data PROM-able. The ROM segment would contain the initializers and would be copied to RAM segment by a start-up routine. In this case, the segments must be exactly the same size and layout.

<table>
<thead>
<tr>
<th>Description</th>
<th>Asm430 Directive (CCE)</th>
<th>A430 Directive (IAR)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reserve size bytes in the .bss (uninitialized data) section</td>
<td>.bss(1)</td>
<td>(2)</td>
</tr>
<tr>
<td>Assemble into the .data (initialized data) section</td>
<td>.data</td>
<td>RSEG const</td>
</tr>
<tr>
<td>Assemble into a named (initialized) section</td>
<td>.sect</td>
<td>RSEG</td>
</tr>
<tr>
<td>Assemble into the .text (executable code) section</td>
<td>.text</td>
<td>RSEG code</td>
</tr>
<tr>
<td>Reserve space in a named (uninitialized) section</td>
<td>.usect(1)</td>
<td>(2)</td>
</tr>
<tr>
<td>Alignment on byte boundary</td>
<td>.align 1</td>
<td>(3)</td>
</tr>
<tr>
<td>Alignment on word boundary</td>
<td>.align 2</td>
<td>EVEN</td>
</tr>
</tbody>
</table>

(1) .bss and .usect do not require switching back and forth between the original and the uninitialized section. For example:

; IAR Assembler Example
RSEG DATA16_N ; Switch to DATA segment
EVEN ; Ensure proper alignment
ADCResult: DS 2 ; Allocate 1 word in RAM
Flags: DS 1 ; Allocate 1 byte in RAM
RSEG CODE ; Switch back to CODE segment
; CCE Assembler Example #1
ADCResult .usect ".bss",2,2 ; Allocate 1 word in RAM
Flags .usect ".bss",1 ; Allocate 1 byte in RAM
; CCE Assembler Example #2
.bss ADCResult,2,2 ; Allocate 1 word in RAM
.bss Flags,1 ; Allocate 1 byte in RAM
(2) Space is reserved in an uninitialized segment by first switching to that segment, then defining the appropriate memory block, and then switching back to the original segment. For example:

; IAR Assembler Example
RSEG DATA16_Z
LABEL: DS 16 ; Reserve 16 byte
RSEG CODE

(3) Initialization of bit-field constants (.field) is not supported, therefore, the section counter is always byte-aligned.

D.3.4 Constant Initialization Directives

<table>
<thead>
<tr>
<th>Description</th>
<th>Asm430 Directive (CCE)</th>
<th>A430 Directive (IAR)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Initialize one or more successive bytes or text strings</td>
<td>.byte or .string</td>
<td>DB</td>
</tr>
<tr>
<td>Initialize a 32-bit IEEE floating-point constant</td>
<td>.double or .float</td>
<td>DF</td>
</tr>
<tr>
<td>Initialize a variable-length field</td>
<td>.field</td>
<td></td>
</tr>
<tr>
<td>Reserve size bytes in the current section</td>
<td>.space</td>
<td>DS</td>
</tr>
<tr>
<td>Initialize one or more text strings</td>
<td>Initialize one or more text strings</td>
<td>DB</td>
</tr>
<tr>
<td>Initialize one or more 16-bit integers</td>
<td>.word</td>
<td>DW</td>
</tr>
<tr>
<td>Initialize one or more 32-bit integers</td>
<td>.long</td>
<td>DL</td>
</tr>
</tbody>
</table>

(1) Initialization of bit-field constants (.field) is not supported. Constants must be combined into complete words using DW.

; Asm430 code
.field 5,3 \n.field 12,4 | ->  DW (30<<{4+3}) | (12<<3) | 5 ; equals 3941
.field 30,8 /
D.3.5  Listing Control Directives

<table>
<thead>
<tr>
<th>Description</th>
<th>Asm430 Directive (CCE)</th>
<th>A430 Directive (IAR)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Allow false conditional code block listing</td>
<td>.cclist</td>
<td>LSTCND-</td>
</tr>
<tr>
<td>Inhibit false conditional code block listing</td>
<td>.fcnolist</td>
<td>LSTCND+</td>
</tr>
<tr>
<td>Set the page length of the source listing</td>
<td>.length</td>
<td>PAGSIZ</td>
</tr>
<tr>
<td>Set the page width of the source listing</td>
<td>.width</td>
<td>COL</td>
</tr>
<tr>
<td>Restart the source listing</td>
<td>.list</td>
<td>LSTOUT+</td>
</tr>
<tr>
<td>Stop the source listing</td>
<td>.nolist</td>
<td>LSTOUT-</td>
</tr>
<tr>
<td>Allow macro listings and loop blocks</td>
<td>.mclist</td>
<td>LSTEXP+ (macro)</td>
</tr>
<tr>
<td>Inhibit macro listings and loop blocks</td>
<td>.mnolist</td>
<td>LSTEXP- (macro)</td>
</tr>
<tr>
<td>Select output listing options</td>
<td>.option</td>
<td>(1)</td>
</tr>
<tr>
<td>Eject a page in the source listing</td>
<td>.page</td>
<td>PAGE</td>
</tr>
<tr>
<td>Allow expanded substitution symbol listing</td>
<td>.ssclist</td>
<td>(2)</td>
</tr>
<tr>
<td>Inhibit expanded substitution symbol listing</td>
<td>.ssnolist</td>
<td>(2)</td>
</tr>
<tr>
<td>Print a title in the listing page header</td>
<td>.title</td>
<td>(3)</td>
</tr>
</tbody>
</table>

(1) No A430 directive directly corresponds to .option. The individual listing control directives (above) or the command-line option -c (with suboptions) should be used to replace the .option directive.
(2) There is no directive that directly corresponds to .ssclist/.ssnolist.
(3) The title in the listing page header is the source file name.

D.3.6  File Reference Directives

<table>
<thead>
<tr>
<th>Description</th>
<th>Asm430 Directive (CCE)</th>
<th>A430 Directive (IAR)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Include source statements from another file</td>
<td>.copy or .include</td>
<td>#include or $</td>
</tr>
<tr>
<td>Identify one or more symbols that are defined in the current module and used in other modules</td>
<td>.def</td>
<td>PUBLIC or EXPORT</td>
</tr>
<tr>
<td>Identify one or more global (external) symbols</td>
<td>.global</td>
<td>(1)</td>
</tr>
<tr>
<td>Define a macro library</td>
<td>.mlib</td>
<td>(2)</td>
</tr>
<tr>
<td>Identify one or more symbols that are used in the current module but defined in another module</td>
<td>.ref</td>
<td>EXTERN or IMPORT</td>
</tr>
</tbody>
</table>

(1) The directive .global functions as either .def if the symbol is defined in the current module, or .ref otherwise. PUBLIC or EXTERN must be used as applicable with the A430 assembler to replace the .global directive.
(2) The concept of macro libraries is not supported. Include files with macro definitions must be used for this functionality.

Modules may be used with the Asm430 assembler to create individually linkable routines. A file may contain multiple modules or routines. All symbols except those created by DEFINE, #define (IAR preprocessor directive) or MACRO are "undefined" at module end. Library modules are, furthermore, linked conditionally. This means that a library module is included in the linked executable only if a public symbol in the module is referenced externally. The following directives are used to mark the beginning and end of modules in the A430 assembler.

<table>
<thead>
<tr>
<th>Additional A430 Directives (IAR)</th>
<th>A430 Directive (IAR)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start a program module</td>
<td>NAME or PROGRAM</td>
</tr>
<tr>
<td>Start a library module</td>
<td>MODULE or LIBRARY</td>
</tr>
<tr>
<td>Terminate the current program or library module</td>
<td>ENDMOD</td>
</tr>
</tbody>
</table>
D.3.7  Conditional Assembly Directives

<table>
<thead>
<tr>
<th>Description</th>
<th>Asm430 Directive (CCE)</th>
<th>A430 Directive (IAR)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Optional repeatable block assembly</td>
<td>.break</td>
<td>(1)</td>
</tr>
<tr>
<td>Begin conditional assembly</td>
<td>.if</td>
<td>IF</td>
</tr>
<tr>
<td>Optional conditional assembly</td>
<td>.else</td>
<td>ELSE</td>
</tr>
<tr>
<td>Optional conditional assembly</td>
<td>.elseif</td>
<td>ELSEIF</td>
</tr>
<tr>
<td>End conditional assembly</td>
<td>.endif</td>
<td>ENDIF</td>
</tr>
<tr>
<td>End repeatable block assembly</td>
<td>.endloop</td>
<td>ENDR</td>
</tr>
<tr>
<td>Begin repeatable block assembly</td>
<td>.loop</td>
<td>REPT</td>
</tr>
</tbody>
</table>

(1) There is no directive that directly corresponds to .break. However, the EXITM directive can be used with other conditionals if repeatable block assembly is used in a macro, as shown:

```
SEQ MACRO FROM,TO ; Initialize a sequence of byte constants
LOCAL X
X SET FROM
REPT TO-FROM+1 ; Repeat from FROM to TO
IF X>255 ; Break if X exceeds 255
EXITM
ENDIF
X SET X+1 ; Increment counter
ENDR
ENDM
```

D.3.8  Symbol Control Directives

The scope of assembly-time symbols differs in the two assemblers. In Asm430, definitions can be global to a file or local to a module or macro. Local symbols can be undefined with the .newblock directive. In A430, symbols are either local to a macro (LOCAL), local to a module (EQU), or global to a file (DEFINE). In addition, the preprocessor directive #define also can be used to define local symbols.

<table>
<thead>
<tr>
<th>Description</th>
<th>Asm430 Directive (CCE)</th>
<th>A430 Directive (IAR)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Assign a character string to a substitution symbol</td>
<td>.asg</td>
<td>SET or VAR or ASSIGN</td>
</tr>
<tr>
<td>Undefine local symbols</td>
<td>.newblock</td>
<td>(1)</td>
</tr>
<tr>
<td>Equate a value with a symbol</td>
<td>.equ or .set</td>
<td>EQU or =</td>
</tr>
<tr>
<td>Perform arithmetic on numeric substitution symbols</td>
<td>.eval</td>
<td>SET or VAR or ASSIGN</td>
</tr>
<tr>
<td>End structure definition</td>
<td>.endstruct</td>
<td>(2)</td>
</tr>
<tr>
<td>Begin a structure definition</td>
<td>.struct</td>
<td>(2)</td>
</tr>
<tr>
<td>Assign structure attributes to a label</td>
<td>.tag</td>
<td>(2)</td>
</tr>
</tbody>
</table>

(1) No A430 directive directly corresponds to .newblock. However, #undef may be used to reset a symbol that was defined with the #define directive. Also, macros or modules may be used to achieve the .newblock functionality because local symbols are implicitly undefined at the end of a macro or module.

(2) Definition of structure types is not supported. Similar functionality is achieved by using macros to allocate aggregate data and base address plus symbolic offset, as shown:

```
MYSTRUCT: MACRO
DS 4
ENDM
LO DEFINE 0
HI DEFINE 2
RSEG DATA16_Z
X MYSTRUCT
RSEG CODE
MOV X+LO,R4
...  ```
## D.3.9 Macro Directives

<table>
<thead>
<tr>
<th>Description</th>
<th>Asm430 Directive (CCE)</th>
<th>A430 Directive (IAR)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Define a macro</td>
<td>.macro</td>
<td>MACRO</td>
</tr>
<tr>
<td>Exit prematurely from a macro</td>
<td>.mexit</td>
<td>EXITM</td>
</tr>
<tr>
<td>End macro definition</td>
<td>.endm</td>
<td>ENDM</td>
</tr>
</tbody>
</table>

## D.3.10 Miscellaneous Directives

<table>
<thead>
<tr>
<th>Description</th>
<th>Asm430 Directive (CCE)</th>
<th>A430 Directive (IAR)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Send user-defined error messages to the output device</td>
<td>.emsg</td>
<td>#error</td>
</tr>
<tr>
<td>Send user-defined messages to the output device</td>
<td>.mmsg</td>
<td>#message(^{(1)})</td>
</tr>
<tr>
<td>Send user-defined warning messages to the output device</td>
<td>.wmsg</td>
<td>(2)</td>
</tr>
<tr>
<td>Define a load address label</td>
<td>.label</td>
<td>(3)</td>
</tr>
<tr>
<td>Directive produced by absolute lister</td>
<td>.setsect</td>
<td>ASEG(^{(4)})</td>
</tr>
<tr>
<td>Directive produced by absolute lister</td>
<td>.setsym</td>
<td>EQU or =(^{(4)})</td>
</tr>
<tr>
<td>Program end</td>
<td>.end</td>
<td>END</td>
</tr>
</tbody>
</table>

\(^{(1)}\) The syntax of the #message directive is: #message "<string>"  
This causes #message <string> to be output to the project build window during assemble/compile time.

\(^{(2)}\) Warning messages cannot be user-defined. #message may be used, but the warning counter is not incremented.

\(^{(3)}\) The concept of load-time addresses is not supported. Run-time and load-time addresses are assumed to be the same. To achieve the same effect, labels can be given absolute (run-time) addresses by the EQU directives.

\(^{(4)}\) Although not produced by the absolute lister ASEG defines absolute segments and EQU can be used to define absolute symbols.

```asm
; Asm430 code ; A430 code
.label load_start load_start:
Run_start: <code>
   <code> load_end:
Run_end:  run_start: EQU 240H
.label load_end run_end: EQU run_start+load_end-load_start
```

```
MYFLAG EQU 23EH ; MYFLAG is located at 23E
ASEG 240H ; Absolute segment at 240
MAIN: MOV $23CH, SP ; MAIN is located at 240
...```

---

1. SLAU157I—May 2005—Revised February 2009
2. IAR 2.x/3.x/4.x to CCE Assembler Migration
3. Submit Documentation Feedback
## D.3.11 Alphabetical Listing and Cross Reference of Asm430 Directives

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>.align</td>
<td>ALIGN</td>
<td>.loop</td>
<td>REPT</td>
</tr>
<tr>
<td>.asm</td>
<td>SET or VAR or ASSIGN</td>
<td>.macro</td>
<td>MACRO</td>
</tr>
<tr>
<td>.break</td>
<td>See Conditional Assembly Directives</td>
<td>.mexit</td>
<td>EXITM</td>
</tr>
<tr>
<td>.bss</td>
<td>See Symbol Control Directives</td>
<td>.mlib</td>
<td>See File Referencing Directives</td>
</tr>
<tr>
<td>.byte or .string</td>
<td>DB</td>
<td>.mlist</td>
<td>LSTEXP+ (macro)</td>
</tr>
<tr>
<td>.cdecls</td>
<td>C pre-processor declarations are inherently supported.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>.copy or .include</td>
<td>#include or $</td>
<td>.mmsg</td>
<td>#message (XXXXXX)</td>
</tr>
<tr>
<td>.data</td>
<td>RSEG</td>
<td>.mlolist</td>
<td>LSTEXP- (macro)</td>
</tr>
<tr>
<td>.def</td>
<td>PUBLIC or EXPORT</td>
<td>.newblock</td>
<td>See Symbol Control Directives</td>
</tr>
<tr>
<td>.double</td>
<td>Not supported</td>
<td>.option</td>
<td>See Listing Control Directives</td>
</tr>
<tr>
<td>.else</td>
<td>ELSE</td>
<td>.setsect</td>
<td>See Miscellaneous Directives</td>
</tr>
<tr>
<td>.elseif</td>
<td>ELSEIF</td>
<td>.setsym</td>
<td>See Miscellaneous Directives</td>
</tr>
<tr>
<td>.emsg</td>
<td>#error</td>
<td>.page</td>
<td>PAGE</td>
</tr>
<tr>
<td>.end</td>
<td>END</td>
<td>.ref</td>
<td>EXTERN or IMPORT</td>
</tr>
<tr>
<td>.endif</td>
<td>ENDIF</td>
<td>.sect</td>
<td>RSEG</td>
</tr>
<tr>
<td>.endloop</td>
<td>ENDR</td>
<td>.setsect</td>
<td>See Miscellaneous Directives</td>
</tr>
<tr>
<td>.endm</td>
<td>ENDM</td>
<td>.setsym</td>
<td>See Miscellaneous Directives</td>
</tr>
<tr>
<td>.endstruct</td>
<td>See Symbol Control Directives</td>
<td>.space</td>
<td>DS</td>
</tr>
<tr>
<td>.equ or .set</td>
<td>EQU or =</td>
<td>.sslist</td>
<td>Not supported</td>
</tr>
<tr>
<td>.eval</td>
<td>SET or VAR or ASSIGN</td>
<td>.ssnolist</td>
<td>Not supported</td>
</tr>
<tr>
<td>.even</td>
<td>EVEN</td>
<td>.string</td>
<td>DB</td>
</tr>
<tr>
<td>.fclist</td>
<td>LSTCND-</td>
<td>.struct</td>
<td>See Symbol Control Directives</td>
</tr>
<tr>
<td>.fnclist</td>
<td>LSTCND+</td>
<td>.tag</td>
<td>See Symbol Control Directives</td>
</tr>
<tr>
<td>.field</td>
<td>See Constant Initialization Directives</td>
<td>.text</td>
<td>RSEG</td>
</tr>
<tr>
<td>.float</td>
<td>See Constant Initialization Directives</td>
<td>.title</td>
<td>See Listing Control Directives</td>
</tr>
<tr>
<td>.global</td>
<td>See File Referencing Directives</td>
<td>.usect</td>
<td>See Symbol Control Directives</td>
</tr>
<tr>
<td>.if</td>
<td>IF</td>
<td>.width</td>
<td>COL</td>
</tr>
<tr>
<td>.label</td>
<td>See Miscellaneous Directives</td>
<td>.wmsg</td>
<td>See Miscellaneous Directives</td>
</tr>
<tr>
<td>.length</td>
<td>PAGSIZ</td>
<td>.word</td>
<td>DW</td>
</tr>
<tr>
<td>.list</td>
<td>LSTOUT+</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
D.3.12 Unsupported A430 Directives (IAR)

The following IAR assembler directives are not supported in the CCE Asm430 assembler:

<table>
<thead>
<tr>
<th>Conditional Assembly Directives</th>
<th>Macro Directives</th>
</tr>
</thead>
<tbody>
<tr>
<td>REPTI</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>File Referencing Directives</th>
<th>Miscellaneous Directives</th>
<th>Symbol Control Directives</th>
</tr>
</thead>
<tbody>
<tr>
<td>NAME or PROGRAM</td>
<td>RADIX</td>
<td>DEFINE</td>
</tr>
<tr>
<td>MODULE or LIBRARY</td>
<td>CASEON</td>
<td>SFRB</td>
</tr>
<tr>
<td>ENDMOD</td>
<td>CASEOFF</td>
<td>SFRW</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Listing Control Directives</th>
<th>C-Style Preprocessor Directives[3]</th>
<th>Symbol Control Directives</th>
</tr>
</thead>
<tbody>
<tr>
<td>LSTMAC (+/-)</td>
<td>#define</td>
<td>ASEG</td>
</tr>
<tr>
<td>LSTCOD (+/-)</td>
<td>#undef</td>
<td>RSEG</td>
</tr>
<tr>
<td>LSTPAG (+/-)</td>
<td>#if, #else, #elif</td>
<td>COMMON</td>
</tr>
<tr>
<td>LSTXREF (+/-)</td>
<td>#ifdef, #ifndef</td>
<td>STACK</td>
</tr>
<tr>
<td></td>
<td>#endif</td>
<td>ORG</td>
</tr>
<tr>
<td></td>
<td>#include</td>
<td></td>
</tr>
<tr>
<td></td>
<td>#error</td>
<td></td>
</tr>
</tbody>
</table>

(1) There is no direct support for IAR REPTC/REPTI directives in CCE. However, equivalent functionality can be achieved using the CCE .macro directive:

```
; IAR Assembler Example
  REPTI zero,"R4","R5","R6"
  MOV #0,zero
  ENDR

; CCE Assembler Example
zeroRegs .macro list
  .var item
  .loop
  .break ($ismember(item, list) = 0)
  MOV #0, item
  .endloop
  .endm
```

Code that is generated by calling "zeroRegs R4,R5,R6":

```
MOV #0,R4
MOV #0,R5
MOV #0,R6
```

(2) In CCE, local labels are defined by $n (with n=0…9) or with NAME?. Examples are $4, $7, or Test?.

(3) The use of C-style preprocessor directives is supported indirectly through the use of .cdecls. More information on the .cdecls directive can be found in the MSP430 Assembly Language Tools User's Guide (literature number SLAU131).
This appendix describes the CCE menus that are specific to the FET.

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>E.1</td>
<td>86</td>
</tr>
</tbody>
</table>
E.1 Menus

E.1.1 Debug View: Advanced Run → Free Run

The debugger uses the device JTAG signals to debug the device. On some MSP430 devices, these JTAG signals are shared with the device port pins. Normally, the debugger maintains the pins in JTAG mode so that the device can be debugged. During this time, the port functionality of the shared pins is not available.

However, when Free Run (by opening a pulldown menu next to the Run icon on top of the Debug View) is selected, the JTAG drivers are set to 3-state, and the device is released from JTAG control (TEST pin is set to GND) when GO is activated. Any active on-chip breakpoints are retained, and the shared JTAG port pins revert to their port functions.

At this time, the debugger has no access to the device and cannot determine if an active breakpoint (if any) has been reached. The debugger must be manually commanded to stop the device, at which time the state of the device is determined (i.e., was a breakpoint reached?).

See FAQ Debugging #9.

E.1.2 Target → Connect Target

Regains control of the device when ticked.

E.1.3 Target → Make Device Secure

Blows the JTAG fuse on the target device. After the fuse is blown, no further communication via JTAG with the device is possible.

E.1.4 Project → Properties → TI Debug Settings → Target → MSP430 Properties → Clock Control

Disables the specified system clock while the debugger has control of the device (following a STOP or breakpoint). All system clocks are enabled following a GO or a single step (STEP/STEP INTO). See FAQ Debugging #12.

E.1.5 Window → Show View → Breakpoints

Opens the MSP430 Breakpoints View window. This window can be used to set basic and advanced breakpoints. Advanced settings such as Conditional Triggers and Register Triggers can be selected individually for each breakpoint by accessing the properties (right click on corresponding breakpoint). Pre-defined breakpoints such as Break on Stack Overflow can be selected by opening the Breakpoint pulldown menu, which is located next to the Breakpoint icon at the top of the window. Breakpoints may be combined by dragging and dropping within the Breakpoint View window. A combined breakpoint is triggered when all breakpoint conditions are met.

E.1.6 Window → Show View → Trace

The Trace View enables the use of the state storage module. The state storage module is present only in devices that contain the full version of the Enhanced Emulation Module (EEM) (see Table 2-1). Once a breakpoint is defined, the State Storage View displays the trace information as configured. Various trace modes can selected when clicking the Configuration Properties icon at the top right corner of the window. Details on the EEM are available in the application report Advanced Debugging Using the Enhanced Emulation Module (EEM) With CCE Version 3 (SLAA393).
E.1.7  Project → Properties → TI Debug Properties → Target → MSP430 Properties →
Target Voltage

The target voltage of the MSP-FET430UIF can be adjusted between 1.8 V and 3.6 V. This voltage is available on pin 2 of the 14-pin target connector to supply the target from the USB FET. If the target is supplied externally, the external supply voltage should be connected to pin 4 of the target connector, so the USB FET can set the level of the output signals accordingly.
This section describes the hardware installation process of the following USB debug interfaces on a PC running Windows XP:

- MSP-FET430UIF
- eZ430-F2013
- eZ430-RF2500

The installation procedure for a Windows Vista system is very similar and, therefore, not shown here.

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>F.1 Hardware Installation</td>
<td>90</td>
</tr>
</tbody>
</table>
F.1 Hardware Installation

1. Connect the USB Debug Interface with a USB cable to a USB port of the PC. (eZ430-F2013 and eZ430-RF2500 can be connected without a cable.)

2. Windows should now recognize the new hardware as an "MSP430 XXX x.xx.xx" (see Figure F-1). The device name may be different from the one shown here.

![Image of Hardware Recognition](image)

Figure F-1. WinXP Hardware Recognition

3. The Hardware Wizard starts automatically and opens the "Found New Hardware Wizard" window.

   **Note:** This Window may not appear. If it does not, the drivers will be installed automatically. Continue with step 13.

4. Click "Next". The Hardware Wizards try to find the driver in the system. If the driver is found, continue with step 8. If not, press "Back" and continue with step 5.

5. Select "Install from a list or specific location (Advanced)" (see Figure F-2).

![Image of Hardware Wizard](image)

Figure F-2. WinXP Hardware Wizard
6. Browse to the folder where the driver information files are located (see Figure F-3). On a default installation the files are located in the following directory:

"C:\Program Files\Texas Instruments\MSP430_USB_DRIVERS_v3"

![Figure F-3. WinXP Driver Location Selection Folder](image)

7. The Wizard generates a message that an appropriate driver has been found.
8. Note that Windows may show a warning that the driver is not certified by Microsoft. Ignore this warning and click “Continue Anyway” (see Figure F-4).

![Figure F-4. WinXP Driver Installation]

9. The wizard installs the driver files.
10. The wizard shows a message that it has finished the installation of the software for "MSP-FET430UIF (TI USB FET) Adapter" (or "MSP430 Application UART").
11. **This step is only for MSP-FET430UIF and eZ430-F2013.** After closing the hardware wizard, Windows automatically recognizes another new hardware device called "MSP-FET430UIF - Serial Port".
12. **This step is for MSP-FET430UIF and eZ430-F2013 only.** Depending on the current update version of the operating system, corresponding drivers are installed automatically or the hardware wizard opens again. **If the wizard starts again, repeat the steps described above.**
13. The USB debug interface is installed and ready to use. The Device Manager lists a new entry as shown in Figure F-5 or Figure F-6.
Figure F-6. Device Manager Using eZ430-RF2500
# Document Revision History

<table>
<thead>
<tr>
<th>Version</th>
<th>Changes/Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>SLAU157I</td>
<td>Added MSP-FET430U100A kit in Section 1.7 and MSP-TS430PZ100A target socket module schematic (Figure B-19) and PCB (Figure B-20). Added emulation features for CC430F513x, CC430F612x, CC430F613x, MSP430F41x2, MSP430F47x, MSP430FG479, and MSP430FG471xx in Table 2-1. Updated MSP-TS430PN80 target socket module schematic (Figure B-15) with information on MSP430F47x and MSP430FG47x. Removed information throughout on MSP-FET430Pxx0 and MSP-FET430X110 kits.</td>
</tr>
<tr>
<td>SLAU157H</td>
<td>Updated information throughout for Code Composer Essentials v3.1.</td>
</tr>
<tr>
<td>SLAU157G</td>
<td>Added MSP-FET430U5x100 kit and MSP-TS430PZ5x100 target socket module schematic.</td>
</tr>
<tr>
<td>SLAU157F</td>
<td>Added crystal information to Section 1.7. Added overview of debug interfaces as Table 1-1. Added eZ430-F2013, T2012, and eZ430-RF2500. Updated information throughout for Code Composer Essentials v3.</td>
</tr>
<tr>
<td>SLAU157E</td>
<td>Added MSP-TS430PW28 target socket module, schematic (Figure B-5) and PCB (Figure B-6). Updated MSP-FET430U28 kit content information (DW or PW package support) in Section 1.7. Added emulation features for MSP430F21x2 to Table 2-1. Updated MSP-TS430PW14 target socket module schematic (Figure B-1). Updated MSP-TS430DA38 target socket module schematic (Figure B-7).</td>
</tr>
<tr>
<td>SLAU157D</td>
<td>Added Section 1.12. Updated Table 2-1. Updated Appendix F.</td>
</tr>
<tr>
<td>SLAU157C</td>
<td>Added emulation features for MSP430F22x2, MSP430F241x, MSP430F261x, MSP430FG42x0 and MSP430F43x in Table 2-1.</td>
</tr>
<tr>
<td>SLAU157B</td>
<td>Renamed MSP-FET430U40 to MSP-FET430U23x0. Replaced MSP-FET430U40 schematic and PCB figures with renamed MSP-FET430U23x0 figures. Added FAQ Hardware #2 in Section A.1. Added FAQ Debugging #4 in Section A.3.</td>
</tr>
</tbody>
</table>

NOTE: Page numbers for previous revisions may differ from page numbers in the current version.
EVALUATION BOARD/KIT IMPORTANT NOTICE

Texas Instruments (TI) provides the enclosed product(s) under the following conditions:

This evaluation board/kit is intended for use for ENGINEERING DEVELOPMENT, DEMONSTRATION, OR EVALUATION PURPOSES ONLY and is not considered by TI to be a finished end-product fit for general consumer use. Persons handling the product(s) must have electronics training and observe good engineering practice standards. As such, the goods being provided are not intended to be complete in terms of required design-, marketing-, and/or manufacturing-related protective considerations, including product safety and environmental measures typically found in end products that incorporate such semiconductor components or circuit boards. This evaluation board/kit does not fall within the scope of the European Union directives regarding electromagnetic compatibility, restricted substances (RoHS), recycling (WEEE), FCC, CE or UL, and therefore may not meet the technical requirements of these directives or other related directives.

Should this evaluation board/kit not meet the specifications indicated in the User’s Guide, the board/kit may be returned within 30 days from the date of delivery for a full refund. THE FOREGOING WARRANTY IS THE EXCLUSIVE WARRANTY MADE BY SELLER TO BUYER AND IS IN LIEU OF ALL OTHER WARRANTIES, EXPRESSED, IMPLIED, OR STATUTORY, INCLUDING ANY WARRANTY OF MERCHANTABILITY OR FITNESS FOR ANY PARTICULAR PURPOSE.

The user assumes all responsibility and liability for proper and safe handling of the goods. Further, the user indemnifies TI from all claims arising from the handling or use of the goods. Due to the open construction of the product, it is the user’s responsibility to take any and all appropriate precautions with regard to electrostatic discharge.

EXCEPT TO THE EXTENT OF THE INDEMNITY SET FORTH ABOVE, NEITHER PARTY SHALL BE LIABLE TO THE OTHER FOR ANY INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES.

TI currently deals with a variety of customers for products, and therefore our arrangement with the user is not exclusive.

TI assumes no liability for applications assistance, customer product design, software performance, or infringement of patents or services described herein.

Please read the User’s Guide and, specifically, the Warnings and Restrictions notice in the User’s Guide prior to handling the product. This notice contains important safety information about temperatures and voltages. For additional information on TI’s environmental and/or safety programs, please contact the TI application engineer or visit www.ti.com/esh.

No license is granted under any patent right or other intellectual property right of TI covering or relating to any machine, process, or combination in which such TI products or services might be or are used.

FCC Warning

This evaluation board/kit is intended for use for ENGINEERING DEVELOPMENT, DEMONSTRATION, OR EVALUATION PURPOSES ONLY and is not considered by TI to be a finished end-product fit for general consumer use. It generates, uses, and can radiate radio frequency energy and has not been tested for compliance with the limits of computing devices pursuant to part 15 of FCC rules, which are designed to provide reasonable protection against radio frequency interference. Operation of this equipment in other environments may cause interference with radio communications, in which case the user at his own expense will be required to take whatever measures may be required to correct this interference.
IMPORTANT NOTICE

Texas Instruments Incorporated and its subsidiaries (TI) reserve the right to make corrections, modifications, enhancements, improvements, and other changes to its products and services at any time and to discontinue any product or service without notice. Customers should obtain the latest relevant information before placing orders and should verify that such information is current and complete. All products are sold subject to TI's terms and conditions of sale supplied at the time of order acknowledgment.

TI warrants performance of its hardware products to the specifications applicable at the time of sale in accordance with TI's standard warranty. Testing and other quality control techniques are used to the extent TI deems necessary to support this warranty. Except where mandated by government requirements, testing of all parameters of each product is not necessarily performed.

TI assumes no liability for applications assistance or customer product design. Customers are responsible for their products and applications using TI components. To minimize the risks associated with customer products and applications, customers should provide adequate design and operating safeguards.

TI does not warrant or represent that any license, either express or implied, is granted under any TI patent right, copyright, mask work right, or other TI intellectual property right relating to any combination, machine, or process in which TI products or services are used. Information published by TI regarding third-party products or services does not constitute a license from TI to use such products or services or a warranty or endorsement thereof. Use of such information may require a license from a third party under the patents or other intellectual property of the third party, or a license from TI under the patents or other intellectual property of TI.

Reproduction of TI information in TI data books or data sheets is permissible only if reproduction is without alteration and is accompanied by all associated warranties, conditions, limitations, and notices. Reproduction of this information with alteration is an unfair and deceptive business practice. TI is not responsible or liable for such altered documentation. Information of third parties may be subject to additional restrictions.

Resale of TI products or services with statements different from or beyond the parameters stated by TI for that product or service voids all express and any implied warranties for the associated TI product or service and is an unfair and deceptive business practice. TI is not responsible or liable for any such statements.

TI products are not authorized for use in safety-critical applications (such as life support) where a failure of the TI product would reasonably be expected to cause severe personal injury or death, unless officers of the parties have executed an agreement specifically governing such use. Buyers represent that they have all necessary expertise in the safety and regulatory ramifications of their applications, and acknowledge and agree that they are solely responsible for all legal, regulatory and safety-related requirements concerning their products and any use of TI products in such safety-critical applications.

TI products are neither designed nor intended for use in military/aerospace applications or environments unless the TI products are specifically designated by TI as military-grade or "enhanced plastic." Only products designated by TI as military-grade meet military specifications. Buyers acknowledge and agree that any such use of TI products which TI has not designated as military-grade is solely at the Buyer's risk, and that they are solely responsible for compliance with all legal and regulatory requirements in connection with such use.

TI products are neither designed nor intended for use in automotive applications or environments unless the specific TI products are designated by TI as compliant with ISO/TS 16949 requirements. Buyers acknowledge and agree that, if they use any non-designated products in automotive applications, TI will not be responsible for any failure to meet such requirements.

Following are URLs where you can obtain information on other Texas Instruments products and application solutions:

<table>
<thead>
<tr>
<th>Products</th>
<th>Applications</th>
</tr>
</thead>
<tbody>
<tr>
<td>Amplifiers</td>
<td>Audio</td>
</tr>
<tr>
<td>Data Converters</td>
<td><a href="http://www.ti.com/audio">www.ti.com/audio</a></td>
</tr>
<tr>
<td>DLP® Products</td>
<td>Automotive</td>
</tr>
<tr>
<td>DSP</td>
<td><a href="http://www.ti.com/automotive">www.ti.com/automotive</a></td>
</tr>
<tr>
<td>Clocks and Timers</td>
<td>Broadband</td>
</tr>
<tr>
<td>Interface</td>
<td><a href="http://www.ti.com/broadband">www.ti.com/broadband</a></td>
</tr>
<tr>
<td>Logic</td>
<td>Digital Control</td>
</tr>
<tr>
<td>Power Mgmt</td>
<td><a href="http://www.ti.com/digitalcontrol">www.ti.com/digitalcontrol</a></td>
</tr>
<tr>
<td>Microcontrollers</td>
<td>Medical</td>
</tr>
<tr>
<td>RFID</td>
<td><a href="http://www.ti.com/military">www.ti.com/military</a></td>
</tr>
<tr>
<td>RF/IF and ZigBee® Solutions</td>
<td>Optical Networking</td>
</tr>
<tr>
<td></td>
<td>Security</td>
</tr>
<tr>
<td></td>
<td><a href="http://www.ti.com/security">www.ti.com/security</a></td>
</tr>
<tr>
<td></td>
<td>Telephony</td>
</tr>
<tr>
<td></td>
<td><a href="http://www.ti.com/telephony">www.ti.com/telephony</a></td>
</tr>
<tr>
<td></td>
<td>Video &amp; Imaging</td>
</tr>
<tr>
<td></td>
<td><a href="http://www.ti.com/video">www.ti.com/video</a></td>
</tr>
<tr>
<td></td>
<td>Wireless</td>
</tr>
<tr>
<td></td>
<td><a href="http://www.ti.com/wireless">www.ti.com/wireless</a></td>
</tr>
</tbody>
</table>

Mailing Address: Texas Instruments, Post Office Box 655303, Dallas, Texas 75265
Copyright © 2009, Texas Instruments Incorporated